I had been running a dhcp server on an old version of isc dhcpd circa 2005, 3.0 something. I just upgraded to ISC dhcpd version isc-dhcpd-4.1-ESV-R6.

Before upgrading, the interface (eth0) had two address assigned to it, on eth0:0 and one eth0:1. But the actual interface eth0 had no address assigned. Only the subnet was handing out address, and this worked fine. Now, after upgrading, it gives me the error:

No subnet declaration for eth0 (no IPv4 addresses).

Which is true, there is only subnets defined for eth0:0 and eth0:1. I tried playing around with my config file, adding a shared-network statement, but nothing worked. Finally, I just assigned an address to the physical interface eth0 and it started happily.

I just want to know if its possible to get the old behavior as I have code that depends on it. Or do I have to assign a dummy address on eth0? The dhcp config looks like this:

ddns-update-style interim;
ignore client-updates;

subnet netmask { 
subnet netmask {


    option ip-forwarding off;
    option domain-name-servers;
    option broadcast-address;
    option subnet-mask;
    option routers;

    default-lease-time 30;
    max-lease-time 60;
  • Is this an error (i.e., it doesn't start/work), or just a warning? Yours is a strange setup, but nothing illegal I can see. – vonbrand Feb 7 '13 at 22:52
  • It does not start. I now found some documentation stating that alias interfaces are not supported in dhcpd anylonger. So I am going to not use aliases anymore. See the note half way down:access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/… – Eric Seifert Feb 8 '13 at 0:17
  • Thinking a bit about it, that makes sense. If the server gets a request on eth0, should it respond via eth0:0 or eth0:1? – vonbrand Feb 8 '13 at 0:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.