1

I'm using a 2020 Macbook Air (M1 version). I've been trying to work out how to install linux to use some programs I need for data analysis, and today tried to follow this guide: https://corellium.com/blog/linux-m1. It didn't work at all, I probably got something wrong, and now my external 1tb hard disk, which I copied a bootable linux image to using the dd command, is formatted weird so that it only allows me to write 268mb to it. I've tried erasing and reformatting using Disk Utility, but no luck. Any guesses?

Note: it was an empty drive, I didn't lose any files.

1
1

Re-create the partition table:

msdos

sudo parted /dev/sdX mklabel msdos

GPT

sudo parted /dev/sdX mklabel gpt

Add a formatted ext4 primary partition:

sudo parted -a none /dev/sdX  mkpart primary ext4 0 100%

Replace sdX with your device name.

2
  • 1
    Hi, I didn't follow this advice, I just erased the disk using diskutils. Thanks anyway! – Michael Beavitt Mar 22 at 22:55
  • @MichaelBeavitt Yes you can create a new partition table using fdisk – GAD3R Mar 22 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.