1

I wanted to try FreeBSD, I was aware FreeBSD doesn't come with a desktop environment by default, and I really would like to use a desktop environment, so I installed one, but it just doesn't work.

I installed FreeBSD to a HDD (There are multiple storage devices inside my computer's case, one 1TB Samsung SSD on which I installed Windows 10, and 3 Seagate HDDs), I wrote FreeBSD-12.2-RELEASE-amd64-dvd1.iso to a USB pen drive and installed FreeBSD to one of the HDDs, after the installation process is complete I started the shell in the new system and followed this guide to install KDE desktop environment, I have done all the steps:

portsnap fetch
portsnap extract
su
pkg install xorg
pw groupmod video -m Estranger || pw groupmod wheel -m Estranger

(the username is Estranger)

vi /boot/loader.conf

(added kern.vty=vt to top of file)

pkg install x11/kde5

(not kde4 because it wasn't found)

vi /etc/fstab

(added proc /proc procfs rw 0 0, I used tabs instead of spaces)

vi /etc/rc.conf

(added:

dbus_enable="YES"
hald_enable="YES"
kdm4_enable="YES"
kdm5_enable="YES"

)

There wasn't a single error message (other than "x11/kde4 not found" or something like that), all commands completed successfully and I believe I have done everything right, but I can't get to the desktop not matter what I do, also there was internet connectivity while using the FreeBSD on the USB drive, but FreeBSD on the HDD doesn't have internet connectivity...

What should I do to make KDE Plasma work on the FreeBSD installation with internet connectivity?


I have installed sddm and added sddm_enable="YES" to etc/rc.conf

And I finally saw the KDE login screen, the problem is its resolution is 640x480 and after I logged in all I can see is a black screen, the cursor is x-shaped, and it just stayed like that for several minutes, and nothing else, so I shutdown the computer;

So how I can change the console resolution and the desktop resolution by editing /boot/loader.conf? My monitor's screen resolution is 1920x1080, aspect ratio is 16:9.

And how can I make KDE actually work instead of just showing a black screen?


KDE defaults to "Plasma (Wayland)" and for whatever reason Wayland didn't work, I don't care, I switched to Plasma and it worked perfectly, I got to the desktop, but the display resolution is 1024x768, and the 4:3 resolution looks really awful on a 16:9 screen, I wanted to change the resolution but settings only gave me 4:3 resolutions and the maximum is 1024x768, I have even tried to add kern.vt.fb.defaultmode="1920x1080" to /boot/loader.conf and rebooted and it didn't work...

What tweaks should I make to use the display resolution 1920x1080?

My dedicated graphics card is NVIDIA Geforce GTX 1050 Ti, and the display is connected to the card via an HDMI cable. The display is running at 1920x1080@60Hz.


Well, I guess I need to install the NVIDIA driver and make further tweaks, the problem is I am behind the notorious Great Firewall of China, the download surely will take a really long time, in fact I haven't even installed Firefox on the FreeBSD installation, because pkg install firefox downloads it really slow, only tens kibibytes per second, I am using an 100M Ethernet connection and the maximum download speed is 11.920928955078125MiB/s, yet downloading Firefox will take about 45 minutes!

Fortunately I can bypass the GFW, I know several ways to bypass it, currently I use ExpressVPN on Windows 10, it also has a Linux version but it doesn't support FreeBSD, however it has a Firefox extension, now I have downloaded Firefox source from archive.mozilla.org and NVIDIA driver from us.download.nvidia.com and ExpressVPN Firefox extension from addons.cdn.mozilla.net, I downloaded the files on Windows 10 while connected to ExpressVPN, now I just need to extract the files in FreeBSD and make install, but big problem, all partitions my Windows 10 can access is using NTFS filesystem, and NTFS can only be mounted by su in FreeBSD, FAT family filesystems are sifted out and I don't plan to use them, the problem is I don't know the command to mount NTFS partitions.

Please help me, though I am fairly new to *nix, I have been tweaking Windows for years and I am very good at it, I am very familiar with control, taskmgr, regedit, mmc, cmd, pwsh and "Sysinternal Suite", and I am currently learning Python, I am planning to switch to Unix operating systems because I want to use open source programs, I want to use open source programs because I am poor and can't buy proprietary programs, though many open source programs have binary releases for Windows, many more only release source code and whenever I wanted to compile something from source on Windows using cmake I was told "configuration failed because of missing dependency foobar" or something to that effect so I downloaded the dependency and when I tried to compile the dependency the dependency of the dependency was missing... you get the picture.

Please, I really need to make these tweaks, I know what I am doing, I have tried Google but Google is really useless when you type complex sentences...

2
  • 3
    You should try SDDM. See the KDE section of the FreeBSD manual. Mar 22, 2021 at 12:51
  • 1
    Did you follow the Handbook at all? I've been running FreeBSD desktops without issue for 17 years and use none of the settings you mention. Your problem is very broad and should be asked on the FreeBSD forum or mailing lists instead.
    – Rob
    Mar 23, 2021 at 12:12

2 Answers 2

0

Not intended to answer your question entirely, but worth noting:

hald_enable="YES"

HAL died around a month before you asked the question here:

kdm4_enable="YES"

That's probably much more archaic. 2018 points of reference:

I echo the suggestion to use SDDM. It's consistent with the quick start for KDE Plasma on FreeBSD:

Graphics firstKDE and the rest


… KDE defaults to "Plasma (Wayland)" …

That's a known issue; please see the quick start.

0

It seems that this is the essence of your issue:

… display resolution is 1024x768 …

Your guess was good:

… driver from us.download.nvidia.com …

Easier to install a FreeBSD-provided package for the port of the required driver.

… NVIDIA Geforce GTX 1050 Ti, …

Via https://www.nvidia.com/en-us/drivers/unix/: the latest production branch version is currently 515.76 (released 2022-09-20), which shows support for the Geforce GTX 1050 Ti. The corresponding port:

  • x11/nvidia-driver

– and FreshPorts shows two commands for adding the package (use either one):


Generally, pay close attention to any package message that appears after installation.

For x11/nvidia-driver, the message is not entirely clear. Please see, for example:

You must log in to answer this question.