1

my problem is very similar to this question asked by Antoine Aubry.

I have an ASUS laptop with Windows 10 and Ubuntu 20.04.2 LTS installed in dual boot. After a recent BIOS update, when I start my computer I am met with the GRUB 2 Command Shell instead of the usual GRUB 2 menu. I tried getting out of the shell by typing exit which prompts me to the normal GRUB 2 menu. The problem is that when I select either Windows or Ubuntu, it goes to a black screen and refuses to boot. At this point, I just press the power button to stop my computer. When I turn my computer back on, the normal GRUB 2 menu directly appears and when I try booting into any OS, it works normally.

I have only had this problem for a week and while it still allows me to use both my Ubuntu and Windows, it is not practical to restart my computer each time. I tried executing these steps but upon entering ls I can't seem to find my Linux partition. I should mention that my Windows partition is installed on my SSD while my Linux partition is installed on my HDD. Grub seems to only be able to list the partitions of my SSD. That is why I wanted to know how I could access my HDD partitions in the Grub Command Shell. I must say that I am not familiar with the Grub boot loader and I apologize for any necessary information that I have failed to share here. Thanks in advance.

6
  • Lets see details, use ppa version with your live installer (2nd option) or any working install, not Boot-Repair ISO: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Mar 22, 2021 at 14:00
  • I'm confused. You start off saying that when you turn on your computer, grub only gives you a prompt and you can't get it to boot, but then you turn it on again, and this time it works? What is it, every other time you power on it works?
    – psusi
    Mar 22, 2021 at 18:40
  • @psusi My computer is only able to boot into any OS once it has failed to boot once. So if I turn it on for the first time in a day, it will prompt me to the Grub Shell and after I exit it, it will be display the usual Grub menu but when selecting any OS, it won't be able to boot. That is only when I turn it off manually and turn it back on again that it takes me directly to the Grub menu and is able to boot. I also noticed something: When I restart my computer from any OS (after it has booted successfully), it becomes unable to boot again and I must restart manually like before.
    – Coko
    Mar 23, 2021 at 6:53
  • @oldfred I used boot-repair and I got the following report: paste.ubuntu.com/p/zH3gqjwGpQ
    – Coko
    Mar 23, 2021 at 12:13
  • @olfred The problem now is that when I restart my computer, it does not display the grub menu but instead boots immediately into Ubuntu and I am unable to boot into Windows.
    – Coko
    Mar 23, 2021 at 12:38

1 Answer 1

0

Okay so I managed to fix my problem in the end by using boot-repair as requested by @psusi. Once I did that my laptop could only boot into Ubuntu and I did not have the choice to select any other OS because the Grub menu did not even show. I decided to open up grub-customizer to see the current configuration and it retrieved my previous configuration. I decided to update the grub with the saved configuration and now everything seems to work as normal. When I boot my computer, I don't see the Grub Shell anymore and it directly goes to the Grub menu from which I can boot to either Ubuntu or Windows. Thank you for providing your help so quick. I'll mark this question as solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.