2

I am using Manjaro 20 gnome. When the linux is installed in my machine. A Nvidia driver was installed with mhwd. But lspci command does not show any nvidia gpu.

command:

lspci | grep VGA

output:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)

Any other commands like,

sudo mhwd -i pci nvidia-linux

or

sudo pacman -S nvidia

results in blank screen. Also nvidia X server does not shows any openGl or x-screen menu. Driver manually downloaded from nvidia did not work. machine is using intel gpu.

mhwd --listinstalled
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2020.11.30               false            PCI


Warning: No installed USB configs!
nvidia-smi
Tue Mar 16 22:39:35 2021       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 460.56       Driver Version: 460.56       CUDA Version: 11.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  GeForce 930MX       Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   41C    P0    N/A /  N/A |      0MiB /  2004MiB |      1%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+
pacman --query | grep nvidia                                                                                                     
lib32-nvidia-utils 460.56-1
linux59-nvidia 460.56-1
mhwd-nvidia 460.56-1
mhwd-nvidia-390xx 390.141-1
nvidia-prime 1.0-4
nvidia-utils 460.56-1
neofetch
██████████████████  ████████   me_sajied@manjaro 
██████████████████  ████████   ----------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: HP ProBook 450 G4 
████████            ████████   Kernel: 5.9.16-1-MANJARO 
████████  ████████  ████████   Uptime: 3 hours, 6 mins 
████████  ████████  ████████   Packages: 1225 (pacman) 
████████  ████████  ████████   Shell: zsh 5.8 
████████  ████████  ████████   Resolution: 1366x768 
████████  ████████  ████████   DE: GNOME 3.38.3 
████████  ████████  ████████   WM: Mutter 
████████  ████████  ████████   WM Theme: Yaru 
████████  ████████  ████████   Theme: Arc [GTK2/3] 
████████  ████████  ████████   Icons: Yaru [GTK2/3] 
                               Terminal: gnome-terminal 
                               CPU: Intel i5-7200U (4) @ 3.100GHz 
                               GPU: NVIDIA GeForce 930MX 
                               GPU: Intel HD Graphics 620 
                               Memory: 1864MiB / 3819MiB

2 Answers 2

0

I know that this is a different approach, that is not connected with OS itself but:

Maybe you could disable the integrated graphic card and enable the 'discrete' (Nvidia in that case) card only?

In most cases, you should be able to do it in UEFI (or using the antique term BIOS) when you boot up your system.

3
  • I found two options in BIOS. UMA graphics and hybrid graphics. Apr 6, 2021 at 11:19
  • UMA is default iGPU, so there is option to disable Nvidia complete (UMA) or keep both of the running. The options that was interesting in your scenario is not present :(. Apr 6, 2021 at 12:52
  • 1
    Because mine is laptop, you will find that option when you connect your monitor to a graphics card. I write this because, I think you could find it useful. Apr 6, 2021 at 14:36
0

In the case of manjaro, the content number 2, 3, 4 and 5 from the manjaro-wiki for gpu from this documentation should be worked.

And for Arch-Linux, the nvidia documentation for NVIDIA gpu should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .