1

I am always getting this error at boot. Is there anything major, and if it is, how could be fixed? I get that it has something to do with my AMD GPU. Here is the setup I have:

  • Cpu: AMD A9-9420 RADEON R5, 5 COMPUTE CORES 2C+3G, 2586 MHz
  • GPU: ATI Stoney [Radeon R2/R3/R4/R5 Graphics], AMD ATI Radeon R5 M230 / R7 M260DX / Radeon 520 Mobile
  • 4GB RAM, 250GB SSD
  • OS: Linux manjaro 5.9.16-1-MANJARO #1 SMP PREEMPT Mon Dec 21 22:00:46 UTC 2020 x86_64 GNU/Linux

Also here's the kernel journal from the last boot:

Mar 16 09:24:57 manjaro systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
 Subject: A start job for unit systemd-backlight@backlight:acpi_video0.service has begun execution
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 A start job for unit systemd-backlight@backlight:acpi_video0.service has begun execution.

 The job identifier is 1270.
Mar 16 09:24:57 manjaro systemd-backlight[875]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Mar 16 09:24:57 manjaro systemd[1]: systemd-backlight@backlight:acpi_video0.service: Main process exited, code=exited, status=1/FAILURE
 Subject: Unit process exited
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 An ExecStart= process belonging to unit systemd-backlight@backlight:acpi_video0.service has exited.
 
 The process' exit code is 'exited' and its exit status is 1.
Mar 16 09:24:57 manjaro systemd[1]: systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-code'.
 Subject: Unit failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
The unit systemd-backlight@backlight:acpi_video0.service has entered the 'failed' state with result 'exit-code'.
Mar 16 09:24:57 manjaro systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
 Subject: A start job for unit systemd-backlight@backlight:acpi_video0.service has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 A start job for unit systemd-backlight@backlight:acpi_video0.service has finished with a failure.
 
 The job identifier is 1270 and the job result is failed.
Mar 16 09:24:57 manjaro audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Mar 16 09:24:57 manjaro kernel: audit: type=1130 audit(1615879497.236:64): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Mar 16 09:24:57 manjaro systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video1...
 Subject: A start job for unit systemd-backlight@backlight:acpi_video1.service has begun execution
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 A start job for unit systemd-backlight@backlight:acpi_video1.service has begun execution.
 
 The job identifier is 1276.
Mar 16 09:24:57 manjaro systemd-backlight[876]: Failed to get backlight or LED device 'backlight:acpi_video1': No such device
Mar 16 09:24:57 manjaro systemd[1]: systemd-backlight@backlight:acpi_video1.service: Main process exited, code=exited, status=1/FAILURE
 Subject: Unit process exited
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 An ExecStart= process belonging to unit systemd-backlight@backlight:acpi_video1.service has exited.
 
 The process' exit code is 'exited' and its exit status is 1.
Mar 16 09:24:57 manjaro systemd[1]: systemd-backlight@backlight:acpi_video1.service: Failed with result 'exit-code'.
 Subject: Unit failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 The unit systemd-backlight@backlight:acpi_video1.service has entered the 'failed' state with result 'exit-code'.
Mar 16 09:24:57 manjaro systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video1.
 Subject: A start job for unit systemd-backlight@backlight:acpi_video1.service has failed
 Defined-By: systemd
 Support: https://forum.manjaro.org/c/support
 
 A start job for unit systemd-backlight@backlight:acpi_video1.service has finished with a failure.
The job identifier is 1276 and the job result is failed.
Mar 16 09:24:57 manjaro audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Mar 16 09:24:57 manjaro kernel: audit: type=1130 audit(1615879497.263:65): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-backlight@backlight:acpi_video1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Mar 16 09:24:57 manjaro ModemManager[412]: <info>  [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:02.3/0000:03:00.0': not supported by any plugin

1 Answer 1

0

Edit the file /etc/default/grub and add the below parameters to the GRUB_CMDLINE_LINUX:

$ sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor"

Do not forget to run update-grub afterwards.

For me that solved the issue! I had it on an ATI/AMD, a rather old gpu. Also I wanted to mention this, didn't break the ability to adjust the screen brightness.

May your htop stats be low and your beard grow long!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .