0

Let's say have a directory 'myshare' with SGID enabled, just for testing I've set in smb.conf:

[myshare]
        comment = myshare
        path = /var/lib/samba/myshare
        create mask = 0664
        directory mask = 0770

As far I understand the directories should be created with 0770, but it don't, they are created with 2770 anyway. So what it's the purporse of that parameter, if it is ignored? Am I missing something?

2
  • Are you creating the files on the client or on the server itself? If the former, did you restart the service after changing smb.conf? Commented Mar 15, 2021 at 0:30
  • Yup, of course I did.
    – sebelk
    Commented Mar 15, 2021 at 10:42

0

You must log in to answer this question.

Browse other questions tagged .