2

I am trying to get IPv6 up and running on my network because I have heard about IPv6 tunnel brokers should be able to help with that.

I don't really understand how it is working, or why I need it, but now I am trying to set it up anyways.

My ISP gave me a router/modem which I have set into bridge mode. I then connected my own OpenWRT router, and that is working fine with IPv4.

Then I followed a tutorial and everything seemed to work, but when I started to test if I had a connection to some IPv6 addresses, and if I could ping myself, then I failed. When I check my packet traffic, then I can see that TX: 14.43 KB (180 Pkts.), so something is happening. But RX: 0 B (0 Pkts.) stays like this. This is after approximately Uptime: 0h 25m 51s

  • I restarted the router in every way. I even did a factory reset and started all over.

  • I tried to change the firewall zone from wan to lan; it didn't help, so I changed it back.

  • I tried putting my updateKey and my password.

  • I tried with a 48bit prefix and the 64bit; it was the same.

I didn't change any other settings.

4
  • Tunnel brokers are not recommended anymore these days. IPv6 should be provided by your ISP now. If they don't, then push them to fix that. If they won't, try to find a better ISP. If you can't, that sucks :/ Mar 15, 2021 at 14:58
  • Thank you. I will push them because I know that it should be possible.
    – mama
    Mar 16, 2021 at 18:04
  • @sandersteffann it is true that tunnel brokers are not preferable, but ipv6 rollout lags in some countries (including here in the uk). Eg Virgin media owns 20% of uk internet connections yet their lack of ipv6 support has been a point of frustration since 2010. Phoning them up to "push them" will do very little. Apr 5, 2021 at 20:24
  • @mama Coming ftom someone who goes out of his way do disable/block anything IPv6 related, it blows my mind that you would want this, without even knowing -- your words -- why you need this.
    – Pourko
    Apr 5, 2021 at 22:07

1 Answer 1

3

This sounds like it could be a couple of things:

  1. The "Client IPv4 Address" isn't set correctly, so the tunnel broker doesn't know who to talk back to. Double check that your public ip address is configured correctly in he.net and it hasn't changed on you.

  2. The Client IPv4 Address configured in OpenWrt is the public IP, but OpenWrt isn't listening on the public ip. This is a super common misconfiguration mistake that he.net puts it in the "Example Configurations" page:

NOTE: When behind a firewall appliance that passes protocol 41, use the IPv4 address you get from your appliance's DHCP service instead of the IPv4 endpoint you provided to our broker.

This means that if you have an OpenWrt router behind the router of your ISP, then the IP address in the configuration in /etc/config/network will have your private ip, not your public one! (surprised me the first time too)

  1. The firewall could really be blocking the traffic. From the faq:

Your IPv4 endpoint address must be reachable via ICMP ECHO_REQUEST (Internet Control Message Protocol). If you are using a NAT (Network Address Translation) appliance, please make sure it allows and forwards IP protocol 41.

1
  • Thank you for your answer. I actually do have my OpenWrt router behind the ISP router, but the ISP router is in bridgemode, and it automatically writes my public IP in the configuration. My public ip is static, and I am sure that it is configured correclty. I am starting to think that I should just drop the idea to get a tunnelbroker, since it is not that relevant to my daily use of the internet.
    – mama
    Apr 9, 2021 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.