I am trying to mount a samba share that is in a Raspberry Pi running OpenWrt to a directory on another Pi (running OSMC/Kodi) in the same LAN.

I am running this command from the Terminal of a Pi running OSMC (Kodi):
smbclient \\\\openwrt\\4TB2 -U root

It prompts for my password and lets me list the files in the 4TB2 share.

However when I try this command from OSMC terminal:
mount -t cifs //openwrt/4TB2 /mnt/4tb2

I get a password prompt but the same pwd does not authenticate me and I get the error:
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This command gives the same error(95)
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.0

The /mnt/4tb2 directory exists. Do I need to make changes to my smb.conf or what is going wrong?

Confusingly, if I try it the other way around... and try to mount a share that is on the Pi running OSMC Pi to a directory on the Pi running OpenWrt... it does work.

So I run this command from OpenWrt and it mounts the 4TB1 share:
mount -t cifs //osmc/4TB1 /mnt/4tb1 -o username=osmc,password=pwd,vers=3.0

Maybe this is a firewall issue with OpenWrt?



  • 2
    What version of SMB is running on the OpenWrt? Mar 14, 2021 at 18:18
  • 1
    In one you've got username root and the other has username osmc. Is that correct? If your password contains a comma please change it for the purposes of the trial so that it does not. What messages are reported by Samba on the OpenWRT device for the failing mount attempts? (Typically /var/log/samba but they may be elsewhere or even switched off.) Mar 14, 2021 at 18:32
  • @NasirRiley I just had that idea myself. smbstatus tells me it is SMB3_11 so I was specifying the wrong protocol in the mount command. This command works: mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.11 Mar 14, 2021 at 18:33

1 Answer 1


I was specifying the wrong SMB protocol version in the mount command.

smbstatus told me OpenWrt was using SMB3_11

So running this command from the OSMC Pi now works:
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .