0

I'm on Ubuntu 20.04/AwesomeWM trying to set the default terminal as Alacritty. I can run it in the terminal with the alacritty command and it pop-up on my screen with no problems, but when I change the value of the terminal variable of my rc.lua from

terminal = "x-terminal-emulator"

to

terminal = "alacritty" 

And restart Awesome with Ctrl+Mod+R. The command Mod+Return don't run any terminal, it does nothing.

Another thing that I tried to do was to change the function from the shortcut Mod+Return from

awful.key({ modkey,           }, "Return", function () awful.spawn(terminal) end,
              {description = "open a terminal", group = "launcher"}),

to

awful.key({ modkey,           }, "Return", function () awful.spawn.with_shell("alacritty") end,
              {description = "open a terminal", group = "launcher"}),

But as you might know, nothing happened. Any solution?

1
  • Can you check with which alacritty the command that is used ? Perhaps it is a local PATH issue
    – Ôrel
    Apr 23, 2021 at 0:44

2 Answers 2

1

I'm not on Ubuntu, but I had the same problem. This solution worked for me:

awful.key({ modkey,           }, "Return", function () awful.spawn.with_shell("LIBGL_ALWAYS_SOFTWARE=1 alacritty") end,
   {description = "open a terminal", group = "launcher"}),

The key is

"LIBGL_ALWAYS_SOFTWARE=1 alacritty"

The issue with GLSL 3.30 I was running into is explained here: https://wiki.archlinux.org/title/Alacritty#Requires_hardware_supporting_GLSL_3.30

1
  • this worked (virtualbox + alacritty). but for some reason the env setting in this form is not accepted in the general 'terminal' variable that is used elsewhere throughout the conf (so was not able to get the menu item for terminal working, only the shortcut)
    – rogerovo
    Feb 26, 2022 at 18:31
0

I would just use your full path to the program:

terminal = "/full/path/to/alacritty"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .