0

I'm working on a Linux server who is in a different time zone than me.

How can I make tmux display, in the status bar, my local time, instead of the server local time (without messing up the server time)?

For info, I'm using tmux 3.1

2
  • 1
    Have you considered just setting TZ= the wanted timezone in your login on the remote, so that all times are shown as local? (see man timezone for TZ values).
    – meuh
    Commented Mar 10, 2021 at 16:53
  • I do now, and it works, Thanks
    – Phantom
    Commented Mar 12, 2021 at 7:31

1 Answer 1

0

You can use on your ~/.tmux.conf the following setting:

set -g status-right '[#(TZ="America/New_York" date +"%%Y-%%m-%%d %%H:%%M")]'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .