I bumped into a strange issue. I run a torrent box on a Pi 4 with Raspbian Buster. I use Transmission daemon and Transmission remote client. I deleted a couple of torrents-folders via the remote client. When I look into the download folder using files explorer on the Pi, the deleted folders still appear. They have the original names plus some random string like "_yh4aoik6". They are empty and when I try to delete them with explorer I get "no such file".

When I list the content of the download folder: pi@host: ls -al the strange folders do not appear.

[EDIT] : the download folder I use is not the standard "Download" folder. I made a soft link to /var/lib/transmission-daemon/downloads/. Moreover, when I browse my custom download folder with the files explorer (pcman) in root mode, the strange folders do not appear neighter.

I don't know how to get rid of these "ghost" folders...

  • Is NFS involved anywhere? Commented Mar 8, 2021 at 12:20
  • nope, no NFS, I didn't add it
    – sugarman
    Commented Mar 8, 2021 at 12:51
  • What is the output of ls -lb under that download file when you're trying to list the contents? Still nothing?
    – Kahn
    Commented Mar 8, 2021 at 15:01
  • no success, there is no escape problem - the names are like this "folder-name_y4ze8xxx"
    – sugarman
    Commented Mar 8, 2021 at 15:27
  • 1
    Might it just be leftover (user-based) cache of the file explorer? Any way to reload directory contents?
    – FelixJN
    Commented Mar 9, 2021 at 10:25

1 Answer 1


Thanks to @FelixJN 's comment I solved the issue. It was just a files explorer software cache problem. The deleted folders hang somehow in the explorer's cache, in some temporary form. As they did not appear in the explorer using root rights, they were bound to the pi user.

Before posting here, I looked into the explorer's options to find some cache option, there was none. So, after FelixJN 's post, I just thought of rebooting, and it was enough.

Usually, I try to dig up to the root cause of the problem, clearing inner files if necessary, but in this case I just wanted it fixed and move on. It is rather rare but rebooting can fix some issues even on Linux, besides beeing a constant in Windows troubleshooting...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .