0

I have two MacOS machines both running zsh and tmux for a local developer environment. The machine I'm stumped on (referred to as machine 2) is reflected in the screen shot. What is not happening is for window 1. I expect it to show zsh* (1 panes) "michael@Michaels-MBP:~/Documents". On machine 1, it does show this.

I am running zsh and oh-my-zsh. tmux and osx plugin enabled. I am running tmux and oh-my-tmux.

I cannot figure out where or what to set to get tmux to behave like it does on machine 1. When I am just in the terminal emulator with zsh, the terminal tab title is michael@Michaels-MBP:~/Documents

enter image description here

1 Answer 1

0

Simply rebind the default choose-tree binding to list the windows according to the format you're looking for:

bind-key w choose-tree -ZF "#{window_name}* (#{window_panes} panes) #{host}:#{pane_path}"

For more information on tmux's FORMAT options, you can reference the man page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.