2

I have a centOS 7.5 server that does not boot up. Only boots up to rescue mode. This happened after a forced reboot of the server. I got the following error on CentOS 7.5 after checking the journalctl -p err

enter image description here

grub2 was installed after getting the correct x86_64 file into the system,

enter image description here

tried to mount the boot/efi, but got the error : Unknown file type "vfat" Then I tried to run dosfsck and correct if there are any dirty bits. There was a dirty bit, and it was corrected.

enter image description here

Tried to mount again, and the same error occurred. Unknown file type "vfat".

[![enter image description here][4]][4]

vfat modules are available and they are of the same version as the kernel. I did not update the kernel in this server. so we can rule out the kernel version mismatch problem.

enter image description here enter image description here

Also tried re-installing the kernel and all the packages related to kernel.

enter image description here enter image description here

Still the /dev/sda1 cannot be mounted to /boot/efi. I'm basically ran out of solutions now. Could you help me with this, please. Also I do not have internet to this server. I can download any file from another computer and transfer to this. Please consider this when writing your suggestion.

My fstab is as follows,

enter image description here

2
  • I only got as far as where it said you have a dirty bit and said no to fixing it and no to fixing BS - boot sector. Did you go back an fix those errors?
    – oldfred
    Commented Mar 7, 2021 at 18:06
  • Don’t run grub2-install, there’s no point if it’s an EFI machine. The disk error at the top is for nvme0n1 and not sda, so it is weird that you are using sda later. Is it the same disk?
    – jsbillings
    Commented Mar 7, 2021 at 19:37

1 Answer 1

4

Some security hardening manuals suggest disabling the loading of unnecessary filesystem types. The examples typically include vfat among the types to be disabled.

But for systems using UEFI, vfat is a necessary filesystem type: the EFI System Partition (ESP) that contains the bootloader *.efi files is typically a FAT32 filesystem, and that is one of the FAT filesystem sub-types handled by the vfat module.

Typically, mounting the ESP is necessary for applying any bootloader updates, and another item in the security hardening manuals usually requires installing any security updates in a timely manner.

Check /etc/modprobe.d/*.conf files for a line like:

install vfat /bin/false

or

install vfat /bin/true

If such a line exists, comment it out and try again.

You should also contact whoever is responsible for the security hardening, as it is obvious this hardening was applied without rebooting the system to test for bad side effects. Perhaps the hardening was tested only on systems with a classic MBR boot style, but applied to systems with UEFI too? In that case, this same error might be present on other hardened systems too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .