0

I am running Ubuntu 20.04 on a Lenovo Thinkpad X1 Tablet. A few years ago I wrote a bash script using soundconverter to transcode some of my music to mp3 files when I need to use a player that only has mp3 capability (like my car and my swimming player). I tried to use my script recently and got the following error

faac gstreamer element not found

I did some research and found that the faac plugin in not included in the Ubuntu 20.04 package gstreamer1.0-plugins-bad nor -ugly. But I also found that there is a lame (mp3 library) gstreamer plugin which is installed. Additionally I found that running soundconverter in gui mode could transcode to mp3 without problem. So I have three possible solutions but don't know how to pursue any of therm

  1. If soundconverter can transcode to mp3 in gui, I am guessing there is some option that will enable this in batch mode. Does anyone know how?

  2. Is there a way to ask soundconverter to use gstreamer's lame plugin rather then the faac plugin to transcode to mp3?

  3. Does anyone know how to install the gstreamer faac plugin on Ubuntu 20.04?

3
1

I realize this is an (relatively) old post, but I was just struggling with this in Ubuntu 20.04, and I though I'd share my workaround.

First, I was getting three error messages with the version of Sound Converter installed with Ubuntu 20.04:

  1. Failed to load module "appmenu-gtk-module"
  2. id3mux gstreamer element not found
  3. faac gstreamer element not found

I fixed the first by installing appmenu-gtk3-module. I fixed the second by installing gstreamer1.0-plugins-bad, but I got stuck on the third.

My workaround came from this this article, which describes a method for installing the latest (v. 4.0.1) version of Sound Converter. Here are the steps:

  1. Uninstall soundconverter:

    sudo apt remove soundconverter

  2. Add the xtradeb PPA:

    sudo add-apt-repository ppa:xtradeb/apps

  3. Update:

    sudo apt update

  4. Install soundconverter:

    sudo apt install soundconverter

  5. Use Software & Updates to remove the PPA, because it includes a lot of other software that you may not want to update to the latest version.

Note that the command line flags are different in the latest version of Sound Converter. You can see the new ones with:

soundconverter -h

There doesn't seem to be a manual entry for it.

With the latest version of Sound Converter and the dependencies above, I was able to do conversions from FLAC to OGG and MP3 without any errors, though I do still get the message:

ERROR: Disabling aac-enc output. Do you have "gst-plugins-bad" installed?

I'm not doing any conversions to AAC, so I guess that's okay.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.