1

I want to make it as simple as possible. So I have downloaded Kali Linux 2021 latest version on my VirtualBox and my host machine runs Windows 10.

I bought a USB wireless adapter which has a Ralink RT5370 chipset (supports monitor mode). I just completed my Kali virtual setup and it is completely fresh.

Yet, my USB wireless adapter doesn't work in VirtualBox Kali but works in my host machine (Windows 10).

In Kali, I can see wlan0 in ifconfig and iwconfig (which means Kali can see the adapter). I can execute ifconfig wlan0 down/up but it doesn't scan any networks. It doesn't show any network in wireless settings and sudo iwlist wlan0 scan returns no results.

And there are 5-6 networks around me (I can see them in host machine). So what should I do to make my adapter work in fresh Kali Linux setup? I can provide any command output information (like lsusb) you can just ask for them. Thanks in advance.

6
  • You need to enable USB passthrough for that device, then you may need to install a 3rd party driver – john doe Mar 7 at 14:56
  • @johndoe Thanks for the answer.There is a driver here : mediatek.com/products/broadbandwifi/rt5370 Can you help me downloading it? – Cemeb Mar 7 at 15:01
  • Try to find one in your kali repo first if at all possible so theres gpg verification built into the install process – john doe Mar 7 at 15:02
  • @johndoe Well I tried "apt-get install firmware-ralink" and some firmwares with that but they all were already downloaded. Is that what you mean? If not I would really appreciate if you can help me what to execute in the terminal to achieve what you mean. Thaks. – Cemeb Mar 7 at 15:07
  • Thats what I was referring to, so if you already tried that then it must be another issue. Did you enable USB passthrough (When in the VM, go to "Devices"->"USB" and select the device you want to be used) . If Windows can use the adapter, then it won't work in the virtual machine – john doe Mar 7 at 15:10
0

According to Debian wiki you need to install firmware-misc-nonfree providing the rt2800usb module driver to make the RT5370 chipset working.

To install the firmware-misc-nonfree package after adding non-free to your sources.list:

echo "deb http://http.kali.org/kali kali-rolling main non-free contrib" |\
sudo tee /etc/apt/sources.list
sudo apt update
sudo apt install firmware-misc-nonfree
2
  • First of all thanks for the answer. Yet, I did exactly what you said but it doesn't seem to work unfortunately... Btw the last command "sudo apt install firmware-nonfree" won't get executed it sais no package or smth like that basically nothing to install with that name. – Cemeb Mar 7 at 20:35
  • @Cemeb I have update my answer. – GAD3R Mar 7 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.