0

I have installed Cairo Dock on Linux Mint which works great except when I go to remove an item from the dock it freezes.

This is because I haven't confirmed the removal of the button from the dialog box. as per this page - http://glx-dock.org/bg_topic.php?t=6145

The problem is 90% of the time I have absolutely no idea where this dialog box is. Sometimes (rarely) it will show on top of all my open applications and I click "Yes" and we go happily on our way, but usually it won't show, and minimizing all applications doesn't reveal it. I've even tried removing an item from the dock with no applications open at all and the dialog box won't show even on top of the desktop.

Any ideas?

1
  • Some details, please. What video card/driver? amd64 or i386? What WM/DE? With or without an xorg.conf?
    – schaiba
    Feb 5 '13 at 13:40
0

I fixed this exact same issue by adding this line to /etc/apt/sources-list:

deb http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu precise main

(Note: I'm running an older version of Linux Mint - change "precise" in the above line to match your system.)

Then run:

sudo apt-get update
sudo apt-get upgrade

It turned out this did not go smoothly so I had to uninstall all the cairo-dock packages first and then install them all.

Now it just works.

0

I am using mint 13 (maya) MATE edition and used to have the same problem.

Here is how I fixed it:

Use the -W or --metacity-workaround to start cairo-dock:

cairo-dock -W

Note this flag is only available with cairo-dock version 3.3. I think Mint 13 LTS has version 3.0 of cairo-dock which does not have that option.

Install cairo from the ppa, instructions here: http://glx-dock.org/bg_topic.php?t=6520

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.