0

My spidev module gets initialized with a value different to what I set it in modprobe.d/spidev.conf.

When I do modprobe -D spidev it returns this. I can see the option for bufsiz is 262144 which is what I want.:

modprobe -D spidev
insmod /lib/modules/5.10.16-sunxi/kernel/drivers/spi/spidev.ko bufsiz=262144

But when I interrogate the bufsiz value, it returns a different value

cat /sys/module/spidev/parameters/bufsiz

Returns this:

524288

What's going on here? Why does the spidev module ignore this settings?

By the way, when I do rmmod spidev and immediately do modprobe spidev the correct bufsiz gets loaded. So it seems like the spidev.conf file is being ignored at boot up.

Hardware/OS details:

uname -r returns : 5.10.16-sunxi Hardware: NanoPi Neo V1.4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.