On my laptop, after the system was booted, it shows the login prompt on tty, where I should put my username and password, but the logger continues to print messages here, it looks like:

=> Initialization complete, running stage 2...
- runit: leave stage: /etc/runit/1
- runit: enter stage: /etc/runit/2
runsvchdir: default: current
[   18.234124] udev[1048]: starting version 3.2.9
[   18.262952] udev[1048]: starting eudev-3.2.9
Void 5.10.8_1 (dell.g4s8) (tty1)

dell g4s8: [   19.828571] 8021q: 201.1Q VLan Support v1.8
[   19.934417] wlp020f3: authenticate with <mac-addr>
[   20.151344] wlp020f3: send auth to <mac-addr> (try 1/3)
[   20.499256] wlp020f3: authenticated

I'm using Void Linux 5.10.8_1 with runit-2.1.2_11

Is it possible to disable log messages printing after login prompt?


2 Answers 2


/dev/tty1 is configured to be the console, and system messages are written to the console. Luckily, Linux configures six virtual terminals by default. You could try to use a different terminal as console, e.g. /dev/tty2. This would require adding console=tty2 to the kernel parameters.

An easier solution would be logging on to one of the other terminals. Press ALT-F2 to switch to /dev/tty2.


The problem was solved by configuring kernel loglevel. I didn't have loglevel config param in my grub.cfg for kernel, it seems the default value is too verbose and prints a lot of debug information after booting up. After changing it to loglevel=4 (KERN_WARNING) the problem was solved. Now my kernel line in grub.cfg looks like:

linux /vmlinux ro loglevel=4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .