0

I have a wired xbox one S controller that doesn't respond.

I'm running the latest and up to date KDE Neon.

The controller appears when I use lsusb, but doesn't respond when I launch a game.

So far I've tried:

  • installing and using the xboxdrv package (which only made the controller disappear from the lsusb list)
  • installing the latest version of xpad (https://github.com/paroj/xpad). I've also tried to follow the debugging steps, which didn't produce any output.

Somehow it ended up working with one game after taking a long time to "connect" (???), but I don't know how it happened and haven't been able to reproduce with another game or with 100% success with the same game.

I've also seen mentioned in older requests for help (2018-2020) that it should be supported natively with more recent kernels and I have 5.4 (not sure how I can upgrade if it's not proposed by neon). I've also been able to plug a xbox360 controller and it worked natively with all games.

Any advice on what I could try or how to make it work ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.