2

I've recently installed two Ableconn PEX-UB159 USB 3.2 Gen 2x2 (20 Gbps) PCIe 3.0 cards into an older server I have that has PCIe 3.0 8x/16x slots. I'm running Ubuntu 20.04.2 LTS on (kernel 5.11-generic) I've also attached two Western Digital 2TB P50 external SSDs (supports USB 3.2 Gen 2x2 speed) to the cards to use as storage. Excited about USB 3.2 Gen 2x2 speeds I went to look to see how it performed. I was surprised/confused to find the output of lsusb (pasted below) seemingly limiting the card and SSD to USB 3.2 Gen 1 speeds (5Gbps) but also listing Gen 2 (10Gbps) as the hub speed?

This got me searching for answers as to why this was the case vs. just USB 3.2 Gen 2x2 speeds. I had read that support for USB 3.2 Gen 2x2 support was in the kernel I was running but I upgraded to 5.11 kernel just in case, still didn't seem to change anything. Below is the output from my machine on release/kernel/lsusb and lspci -- any help figuring this out would be much appreciated or at least being pointed in the right direction. I'd love to run this at maximum theoretical speed vs. what it's at now.

Release:

Description:    Ubuntu 20.04.2 LTS
Release:    20.04
Codename:   focal

Kernel: 5.11.0-051100-generic

Here's the output from lsusb -tv w/ drive in question

$ lsusb -tv
...
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 10000M
    ID 1d6b:0003 Linux Foundation 3.0 root hub
    |__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=uas, 5000M
        ID 1058:2642 Western Digital Technologies, Inc.
...
$ lspci -tnnv
...
 +-01.0-[04]----00.0  ASMedia Technology Inc. Device [1b21:3242]
...

Just pasting output from one of the 2TB SSD's b/c the output's basically identical for both so the post isn't excessively long/duplicitous.

$ sudo dmesg
...
[    4.419915] usb 5-1: new SuperSpeed Gen 1x2 USB device number 2 using xhci_hcd
[    4.440404] usb 5-1: New USB device found, idVendor=1058, idProduct=2642, bcdDevice=10.03
[    4.440411] usb 5-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[    4.440419] usb 5-1: Product: Game Drive
[    4.440435] usb 5-1: Manufacturer: Western Digital
[    4.440438] usb 5-1: SerialNumber: ################
[    4.466830] scsi host5: uas
[    4.467640] scsi 5:0:0:0: Direct-Access     WD       Game Drive       1003 PQ: 0 ANSI: 6
[    4.468274] scsi 5:0:0:1: Enclosure         WD       SES Device       1003 PQ: 0 ANSI: 6
[    4.468664] sd 5:0:0:0: Attached scsi generic sg3 type 0
[    4.468850] scsi 5:0:0:1: Attached scsi generic sg4 type 13
[    4.468993] sd 5:0:0:0: [sdc] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[    4.469066] sd 5:0:0:0: [sdc] Write Protect is off
[    4.469071] sd 5:0:0:0: [sdc] Mode Sense: 57 00 10 00
[    4.469192] sd 5:0:0:0: [sdc] Write cache: enabled, read cache: enabled, supports DPO and FUA
[    4.469703] sd 5:0:0:0: [sdc] Optimal transfer size 33553920 bytes
[    4.479734] usb 7-1: new SuperSpeed Gen 1x2 USB device number 2 using xhci_hcd#
[    4.481013] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null). Quota mode: none.
[    4.481417] scsi 5:0:0:1: Failed to get diagnostic page 0x1
[    4.482878] scsi 5:0:0:1: Failed to bind enclosure -19
...

Things I've tried so far:

  • Upgrade to kernel 5.11
  • Boot w/ SSDs attached vs. attaching after
  • Attach SSDs after booting
  • Run a single card with 1 SSD vs. two (tried both 8x and 16x slot -- same result)
  • Live boot Linux Mint Cinnamon, Ubuntu 20.10 -- same result
  • Double checked cables are rated for USB 3.2 Gen 2x2 as well -- says it is

Not sure what else to do next? Any help is greatly appreciated!

6
  • (1) Did you check actual transfer speed? Possibly lsusb reported speeds don't take Gen 2 into account yet, if lsusb isn't updated for it, even though the kernel is (though that depends on how lsusb gets that information). (2) Problems with cabling can decrease the speed, e.g. if the controller has to fall back onto one lane instead of two. – dirkt Mar 3 at 5:52
  • 1
    (1) I've made sure I'm running latest lsusb. Speeds from benchmark is 850 MB/s read, 760 MB/s write and it's around 650 MB/s for the second drive (same drive, different PCIe 3.0 bus). I undertand that 20Gbps is theoretical maximum, not guaranteed but I'd hoped to get close to 2000 MB/s vs. half that. (2) I have a certified "superspeed plus 20gbps" cable arriving friday. Will report back. Thanks for your help! – bedlam Mar 3 at 15:20
  • 1
    Got a USB 3.2 Gen2x2 cable, plugged it in, still no 20000mbps. Any other ideas? No change. I also tried Ubuntu 20.04 Server (same exact lsusb speeds) – bedlam Mar 5 at 20:47
  • Yes, it does not work as should; speed must be the double [anandtech.com/show/16133/…. Talking about motherboard side: (1) does it have the latest BIOS? (2) does the BIOS limit PCI-E lanes in some way? – mattia.b89 Mar 8 at 6:01
  • I will try changing BIOS settings and let you know! BIOS is latest version. – bedlam Mar 8 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.