0

I had a old version of emacs, I removed it and install a new one. For this new install I got a gz file, and compiled in my laptop. After a successful installation I got a small situation:

If I type: emacs-26.3 all works fine, the EMACS version 26.3 runs perfectly.

However if I just type emacs I get:

bash: /usr/bin/emacs: No such file or directory

I would like to type emacs and open emacs-26.3 version.

Please, someone has some suggestion to solve it. Thanks

2
  • 3
    Does it change if you type hash -d emacs? – steeldriver Mar 2 at 22:26
  • @steeldriver thanks a lot! It works! – Rafa Mar 2 at 22:30
0

Normally the emacs is just a symbolic link that is automatically created during install so you can simply add a symbolic link sudo ln -s /usr/bin/emacs-26.3 /usr/bin/emacs

NOTE: Those are the correct paths for Arch but you probably want to verify the install location with which emacs-26.3

1
  • I tried the suggestion from @steeldriver and worked. Thank you! – Rafa Mar 2 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.