Tried to have debian testing by upgrade it via apt package manager, so it was done

$ cat /etc/debian_version /etc/os-release 
PRETTY_NAME="Debian GNU/Linux bullseye/sid"
NAME="Debian GNU/Linux"

and listed all to ensure a newer libc6, but surprisingly it's not upgraded yet so then:

$ sudo apt upgrade libc6/testing


The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (< 2.29) but 2.31-9 is to be installed
 libc6 : Breaks: libgegl-0.4-0 (< 0.4.18) but 0.4.16-0.1~mx19+1 is to be installed
 libc6-dev : Depends: libc6 (= 2.28-10) but 2.31-9 is to be installed
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not installable

How can it be not upgraded having libc6 > 2.28 which is (mostly) only 2.31 distributed now as printed above, although it's already full upgrade ? Please help solve.


1 Answer 1


Make sure you have set your sources.list correctly, here is how to override the non-debian repository (as said @A.B in this comment) :

sudo rm /etc/apt/sources.list.d/*

cat <<EOF |sudo tee /etc/apt/sources.list
deb http://deb.debian.org/debian/ unstable main

Then run:

sudo apt purge libgcc1 # not available in Sid
sudo apt update
sudo apt dist-upgrade

You must log in to answer this question.