1

Okay so this is driving me crazy. I need help.

I have a Kali linux machine set up with VirtualBox which has been working fine until two days ago. Then, it started doing a super weird thing when I log in: I enter my credentials, then login screen dissapears (desktop background still visible), then the screen "blinks" and goes dark. If I want to use the machine I have to enter tty.

The weird thing is that when I reboot the computer with the tty the machine doesn't do that, it logs me as it should.

I've tried all kind of things, changing lightdm (slim, gdm), checking drivers, checking X11... Thank you in advance.

EDIT: Reinstalled Kali with a new iso (2021.1), started using it, 2 days later same problem in the new one :(

Update: So far, tried in the new machine to change lightdm to dgm3 and it worked...the first time. The following bootups made the machine freeze without even login in.

4
  • what did you do two days ago? – jsotola Mar 1 at 23:18
  • "when I reboot the computer" Which computer - the virtual one or the host? When you are forced to log in via command line, can you check the status of your X11? Find something in the log? – berndbausch Mar 2 at 0:17
  • 1
    @jsotola Started the machine as always, didn't update, upgrade or modified anything that could lead to this error – alex55132 Mar 2 at 7:02
  • @berndbausch Reboot the virtual machine(Srry If I didn't say it clearly) X11 server is already running and apparently is all good. Logs dont show any error nor warning that could lead to this. Checked X11 logs, lightdm... Etc – alex55132 Mar 2 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.