0

I have 3 virtual machines:

  1. master@master-virtualbox
  2. worker1@worker1-virtualbox
  3. worker2@worker2-virtualbox

When I try to copy ssh id from worker1 to master, asked for password which I dont know what is it. I dont even know what password!!!. Anyway, I tried the password I created for all the machines (They all are same password) and ended up with

worker1@master-virtualbox: Permission denied (publickey,keyboard-interactive).

I dont even have master host or master user in the worker machines vice-versa no worker1 or worker2 users in master machine. I dont know where is it trying to connect. By the way I get similar error when I run start-dfs.sh command from my master machine.

worker1@worker1-virtualbox: master@worker1-virtualBox: Permission denied (publickey,keyboard-interactive).
worker2@worker2-virtualbox: master@worker2-virtualBox: Permission denied (publickey,keyboard-interactive).

However when I connect (ssh worker1@worker1-virtualbox or ssh worker2@worker2-virtualbox) from master or from worker machines to connect master (ssh master@master-virtualbox) or worker to worker(ssh worker1@worker1-virtualbox or ssh worker2@worker2-virtualbox) etc. Connecting without password , no problem. Any help will be appreciated. Thanks in advance

1 Answer 1

0

When you ssh-copy-id or ssh there must be a valid login for that user on the destination. So when you attempt to ssh-copy-id worker1@master-virtualbox the password your being prompted for is the password for worker1 which does not exist. To do what you are trying you will have to create accounts and password for each on the master. The naming your using makes this a little confusing but do you understand what I am saying.

The connections from master to worker works because you are using there logins.

Basically if you want to connect worker1 to master and dont want to use the root account you will have to create a worker1 user on the master.

2
  • Thanks for the quick response. I add all users to each machine and I managed to ssh-copy-id master-VirtualBox but still have problem but I understand the issue now. So I'll sort it out. Thanks
    – omer
    Mar 1, 2021 at 21:36
  • Anytime if we can help just ask hope it all works out for you. Mar 1, 2021 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .