0

I am trying to extract a xz archive, however, around half way through decompression I get the error Compressed data is corrupt.

I have tried using xzcat and using the --ignore-check flag in case that is the problem, however I run into the same issue.

I have also tried using tar to extract to see if anything would be different, but I get the same results:

xz: (stdin): Compressed data is corrupt. 
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

How would I repair or atleast salvage some data by skipping the corrupted byte(s)?

2
  • Since the data is compressed, your best bet is to try and reobtain it from the source. – cutrightjm Feb 26 at 15:05
  • Yep... nothing you can do. Once a compressed stream is corrupt, there is no way to recover later data since it's meaning depends on all of the previous bytes. – psusi Feb 26 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.