2

I was using Linux mint and windows 10 together(in different partitions). Few months I was using freely. Today I got a message in windows 10(new updates available or shutdown and update) then, I clicked on shutdown and update. After finishing the update 50% automatically restarted my laptop. It happens multiple times when we install windows 10. Since than I am unable to start my laptop enter image description here

I am not sure why this happens as far as I know this happens when there's no grub loader.

Here what I tried enter image description here

I was watching some videos and searching on Google how to fix it. I got an solution I amt not sure it will work or not they took a live USB and they had windows on there USB but, I have Linux mint in my USB will it work? https://youtu.be/xx2CFufykB0

I am using live USB(Linux mint). I was trying to mount linux disk. sudo mount /dev/sda4 /mnt. Then, I get an error mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sda4, missing codepage or helper program, or other error.

Device Boot Start End Sectors Size Id Type /dev/sda1 * 1026048 272532369 271506322 129.5G 7 HPFS/NTFS/exFAT /dev/sda2 272533504 273694719 1161216 567M 27 Hidden NTFS WinRE /dev/sda3 273696768 274747391 1050624 513M b W95 FAT32 /dev/sda4 274749438 625141759 350392322 167.1G 5 Extended /dev/sda5 623144960 625141759 1996800 975M 82 Linux swap / Solaris enter image description here

/dev/sda4 is linux. I am sure for disk size

enter image description here

enter image description here

When I use Windows 10 above disk are visible without linux mint disk. When I use Linux Mint every disks are visible. Here something happening like this.

19
  • There are many ways to fix this. One of the easiest way in my opinion is to use sourceforge.net/projects/supergrub2 to boot into Linux, then use grub-install and update-grub to re-install and re-configure GRUB.
    – Hermann
    Commented Feb 26, 2021 at 9:12
  • @Hermann Look I am on Linux mint from live USB. How can I solve it now? I was trying sudo mount /dev/sda4 /mnt to mount my linux disk. Then, I get an error mount: /mnt: wrong fs type, bad option, bad superblock on /dev/sda4, missing codepage or helper program, or other error. Even, I was trying to mount it manually from file manager but, there's no disk like this. But, I found windows 10. When I tried grub-install from terminal I get an error. Installing for i386-pc platform. grub-install: error: install device isn't specified.
    – user449077
    Commented Feb 26, 2021 at 9:26
  • @Hermann I tried sudo grub-install /dev/sda4 Error :Installing for i386-pc platform. grub-install: error: failed to get canonical path of /cow'.` I tried it also. Then, what to do?
    – user449077
    Commented Feb 26, 2021 at 9:34
  • after set prefix=(hd0,msdos6)/boot/grub you must set root=(hd0,msdos7) , i wrote msdos7 as example you have to find your real root partition. take a look at this link: paolozaino.wordpress.com/2017/12/09/… Commented Feb 26, 2021 at 10:07
  • 1
    @JonasBerlin I have edited
    – user449077
    Commented Feb 26, 2021 at 10:11

0