1

Both Firefox and Brave act on the prefers-reduced-motion CSS media query.

I found out that gtk-enable-animations=false is in nano ~/.config/gtk-3.0/settings.ini

This file does not even has a message that its controlled by KDE.

And my ~/.gtkrc-2.0

gtk-cursor-theme-size=24
gtk-enable-animations=0

# File created by KDE Gtk Config
# Configs for GTK2 programs 


gtk-font-name="Ubuntu,  12"
gtk-theme-name="Adwaita"
gtk-icon-theme-name="breeze-dark"
gtk-fallback-icon-theme="hicolor"
gtk-cursor-theme-name="breeze_cursors"
gtk-toolbar-style=3
gtk-menu-images=1
gtk-button-images=1
gtk-primary-button-warps-slider=0

Interestingly the message the KDE controls the file is below the gtk-enable-animations=0 anyway I did enable it and rebooted, and it back to disabled. I am actually not sure if and what version of GTK Firefox and Brave use. But I was not able to enable it even temporary. I guess I would have to reload KDE anyways. It looks like this is the cause

What I need to know is what KDE setting controls this and where to find that setting. Or whatever I have to do to now have my web browsers assume I do not want animations.

Pretty sure this has happened on its own after one of the recent updates.

// actually it seems the changes are in fact persistent across boots and the is also a ~/.config/gtk-4.0/settings.ini that did NOT have the animations disabled ...

2
  • We don't use version tags for distros. unix.meta.stackexchange.com/q/3102/70524 And even if we did, that you're using Tumbleweed is mostly irrelevant to the problem itself. It could have happened even on non-Tumbleweed as well.
    – muru
    Feb 25, 2021 at 15:29
  • Wrong. Tumbleweed is not a "version number" it's a rolling release distribution on the very curling edge. And wrong #2 I doubt this happens on some general distro update for any non rolling release distro because they are tested and things like this probably are figured out before the packages are shipped. I expect this is very much related to the fact that the packages change every other day. openSUSE !== openSUSE Tumbleweed. Therefore, your rule is bad and the tag is bad for my distro. Feb 25, 2021 at 18:15

1 Answer 1

0

TLDR: Go to system settings, move the "Animation speed" slider to another value that is not "Instant" and apply. Return to old value if preferred.

This just happened to me after updating to Kubuntu 21.04, so it's not distro-related. Really annoying since I'm a web developer and I spent like 10 minutes trying to understand why the animations in the project I'm working on suddenly stopped working.

After understanding it was due to the reduced-motion @media query, I found your answer and your findings really helped me understand the problem, so thanks for that.

After some investigation, I found this: https://phabricator.kde.org/D26825. Basically a guy had a good idea to bind the "Animations speed" slider in system settings to set the gtk option to false when moved to "Instant".

It seems like, as per usual lately with KDE, a good idea got a bad implementation and even if your current setting was not "Instant", the gtk option would be set to false until you moved the slider.

3
  • 1
    I have the same issue now, updated to Kubuntu 21.10 recently and now every time I reboot my machine, this setting is disabled again :(
    – jumper85
    Oct 28, 2021 at 13:14
  • Yeah, still not fixed in 21.10. I was advised to report on KDE's bug tracker, but I have years-old unanswered reports so I won't bother. Maybe you are luckier if you try.
    – Marc
    Oct 29, 2021 at 14:27
  • Kubuntu 22.04, still happening. Have to set the slider again after every reboot. Mar 14 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .