After installing Debian 6.0 rc1, I can't do anything as administrator because I cannot login as root (but I did setup the password during installation) and user is not a sudoer either.

Did I miss anything?

[update] I used Live CD to boot and edit the sudoer file, and the problem is fixed.

  • Can you post the solution as an answer? There's an "answer your own question" button at the bottom. Then you can accept it and the question will be marked as solved (and you'll get rep for accepting an answer) – Michael Mrozek Feb 7 '11 at 2:32

How are you trying to login? From the terminal, ssh, X (GDM/KDM/XDM/etc)?

Have you tried suing to root from the user account?

Having set a root password but not being able to login to the terminal as root or suing to root would indicate a problem. Not being able to login to X or via ssh as root would more likely be the result of good default security restrictions. If su works but you still want sudo then you can just run su -c visudo then add your useraccount to the sudoers file.

  • Thanks for the response. I was able to login in the UI but says that my user is not a sudoer. I made sure to set the root password during startup. It always says authentication failure when i log in using su. i was able to resolve it by booting to a live cd and added my user as sudoer. – Marc Vitalis Jan 24 '11 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.