I am trying to get a SMB connection to a HTB box with an open SMB port. But smbclient throws an "ERROR NT_STATUS_IO_TIMEOUT" error every time. I've added

client min protocol = CORE 
client max protocol = SMB3

to my /etc/samba/smb.conf file but this hasn't helped. What can I do?

  • This might help: unix.stackexchange.com/questions/235777/… Feb 23, 2021 at 23:51
  • smbclient doesn't use those configuration values. I can't remember offhand what the parameter is but if you read man smbclient you'll see there is an option to set the SMB version level. Having said that, I don't recall having seen this particular error with a version mismatch
    – roaima
    Feb 23, 2021 at 23:54

2 Answers 2


I also had this problem when doing the WINDOWS FUNDAMENTALS module in HTB. To fix this, when you RDP into the Windows machine just turn off the firewall and you'll not only be able to ping the box but your smbclient command will work too.


I ran into this recently after it had been working ever since I built & installed this Windows 10 computer, as well as on every other machine on the network. The particular issue was that not a single Linux machine could mount shared Windows 10 drives, even though they had all previously been able to. After seeing Sean Gray's response above, I checked, and sure enough, the last Microsoft update had switched my network to Public and disabled all my firewall settings. Lovely. I reset the adapter and made my private network private, as it should have been, fixed the firewall, and now everything works correctly.

The next time you get a 'mount error(2): No such file or directory', or the referenced NT_STATUS_IO_TIMEOUT error if you're using smbclient to troubleshoot, then check your Windows firewall AND your Windows network adapter settings. That "public/private" network setting just might be what's biting you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.