When installing LAMP server, I went for tasksel, and got my DE (Xfce) and seemingly also display manager (LightDM) removed (this is a known "bug", believe it or not). Now I just need to connect to wifi to start reinstalling the removed components.

However, it seems there's very little to start with. I have no wireless interface (ifconfig -a shows only enp0s and lo). I have no nmcli, iw, iwconfig, iwlist, wpa_supplicant, ifup or ifdown. By way of relevant tools, I have at least (and maybe only) ip, dhclient, netplan and ifconfig. systemctl status network-manager shows that network-manager.service is loaded and inactive (dead). I can activate it w/ systemctl restart network-manager, but that's it. I edited /etc/network/interfaces, to include the wireless info, as described here, and rebooted. This bought me nothing. lspci -v assures me I (still) have Intel Wireless 8265 / 8275 network controller. The question: Is there anything I could try to do to connect to wifi other than a complete reinstall of the distro? Something to get things going. I'm on Ubuntu 18.04 LTS

  • 1
    I am not super familiar with the exact names of the packages on Ubuntu but it seems you you know what you need already you can download those packages directly from packages.ubuntu.com then manually install them with sudo apt install /path/to/package – Jason Croyle Feb 23 at 22:45
  • @JasonCroyle I could e.g. try to install network-manager (confusingly, I have the service but not the package installed), which would give me nmcli (+ iw, modemmanager and wpa_supplicant as its dependencies). This would mean downloading ca. 30 dependencies, many of which have dependencies, some of which have dependencies, etc., all of which have to be downloaded. It's feasible, but reinstalling a distro is probably easier – jaam Feb 24 at 0:22
  • 1
    Your probably correct there I am assuming you have already checked that all the dependencies where removed also. The only other idea I have would be booting from a live usb and then chroot into the install and repair it that way. – Jason Croyle Feb 24 at 0:35

The issue was solved w/ chroot (thanks to Jason Croyle for the tip). Perhaps "cheating" (as I made the wifi connection in another system), but an "honest" solution wasn't forthcoming. Luckily, I had another Linux installed on the computer, so didn't even have to use a live USB. The procedure itself is described here. I also made a script, as suggested here (actually two: one to chroot and the other for the cleanup after the chroot). With the script I got the "No tty present and no askpass.." error on sudo chroot /mnt/sda8 /bin/bash, solved by sudo -S chroot /mnt/sda8 /bin/bash (where -S explicitly asks for a password from stdin).

I could also comment on how to recover from the havoc wrecked by tasksel, but given SE's "laser-like focus", I probably shouldn't. So just do yourself a favor and avoid tasksel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.