1

I have switched to a new computer and tried to install Beowulf 3.1.0 in a pure-EFI setting.

I have tried installing on a SATA SSD as well as a a m.2 PCIe SSD. Originally, the plan was a dual boot install with Win10 being installed first, however after several failed attempts, I scraped Win10 and went for a Linux-only install.

Installation seems to run smoothly but after reboot grub presents itself without the "graphical" selection menu but instead delivers the line "Minimal BASH-like line editing is supported..."

After 5 hours of installing and re-installing I tried installing Debian Buster 10.8 (I understand, Beowulf 3.1.0 is based on 10.8). With debian the installation works out of the box. Also, performing the installation in legacy-mode works

I have found following hints regarding this:

  • EFI Partition may be missing or too small: I tried both with guided partitioning and manual partitioning, I created EFI partitions up to 1 gb without success.
  • Grub may have to be re-installed: I tried to chroot into the installation and did a grub-install (after mounting the efi-partition). This did not solve the issue
  • Grub.cfg may be missing: I compared the grub.cfg from Debian and Devuan. Superficially they look very similar.

Do you have any hints what else to try? Is this a bug in devuan, which is not present in debian?

I have asked this question on the Devuan Mailing List, my impression after posting is, that the list has relatively little activity, so I allowed myself a cross posting, as this is somewhat urgent

0

If your PC is a 32-bit UEFI-based (yes, with a 64 bit CPU... thanks Intel !) PC, you'll need to install the grub-efi-ia32 package while using the liveCD before you install Devuan.

This happens when you have an Atom, Celeron Silver or Pentium Silver CPU based cheap PC released from 2011 up to around 2017.

Watch for the "IMPORTANT NOTES" section: https://files.devuan.org/devuan_beowulf/desktop-live/README.desktop-live.txt

Pretty weird from Devuan that they didn't integrate that package too on the iso. Anyway, enjoy your far less buggy Debian from "wontfix"-ed systemd bugs !


One other unlikely issue would be that you have installed Devuan with a separate /boot, and that Devuan got a bug and wouldn't boot if you did so. This bug was in Devuan 3.0 isos, they spot it after the release and should now be fixed by now on 3.1 isos (which you do use) as it was planned.

6
  • HAHAHA, thanks for your answer. While I have to check tonight, it might have solved my issue without solving it. The Readme you pointed me to contains a section about installing on HP computers (which I am trying to do). It seems there are some issues there with HP searching for files differently than other computers. – Jonathan Feb 23 at 7:33
  • Please also do tell what is your PC and the CPU you have so we can see if you do have such 32-bit UEFI and confirm the issue. But yeah, UEFI is an ungodly mess that brings more problems than it solves. – X.LINK Feb 23 at 7:34
  • 1
    My PC is a HP Elitedesk 705 G2 with an AMD A8-8650 CPU – Jonathan Feb 23 at 8:01
  • 1
    My impression yesterday was: I satrted with Linux in 1999. It was a mess and without proper C-coding skills you were utterly lost. During the last 20 years it became more and more usable until we reached a tipping point where it was actively made worse again. UEFI is one example, systemd another. Now, we are back in 1999 but this time, C-skills won't save you beacause the magic is hidden from you. – Jonathan Feb 23 at 8:04
  • Well it's probably the HP issue then, AMD is not known to use 32-bit UEFI with 64-bit CPUs. For the second part of your comment: True, true... Every over-engineered thing started around 10 years ago. The peak of the PC era done right was probably 2006 to 2011. – X.LINK Feb 23 at 8:17
0

So in the end it was neither.

I yesterday realized, that the UEFI of my HP-PC was from 2016, while HP (thankfully) provided an updated UEFI from 2020. After updating the UEFI it works. Probably some non-conformance with the original spec which was solved somewhere in the last 5 years?

Anyway, kind thanks for the suggestion and hope that this is helpful to someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.