0

I'm having an error message in my Linux terminal after trying to install adb debugging sideloader through my Chrome OS. I don't think it has anything to do with that, the error message I'm seeing when I run sudo apt-get install android-tools-adb is:

E: Type 'new' is not known on line 4 in source list /etc/apt/sources.list
E: The list of sources could not be read.

What is this error message and how do I fix it?

3
  • It continues to show when when I try to install other things in my Linux terminal too
    – Dexsas
    Feb 23, 2021 at 2:42
  • 2
    Please post your /etc/apt/sources.list; add to your question. Feb 23, 2021 at 3:07
  • Welcome, please add the output of cat /etc/apt/sources.list to your question.
    – GAD3R
    Feb 23, 2021 at 11:03

2 Answers 2

2

Post the contents of your /etc/apt/sources.list file or if you first want to check you can see if line 4 in that file looks different then the rest. It appears that your sources.list got corrupted somehow probably when you where trying to install the sideloader.

Jason C.

4
  • /etc/apt/sources.list bash: /etc/apt/sources.list: Permission denied
    – Dexsas
    Feb 23, 2021 at 7:53
  • Am I typing the way to view this correctly, or is it something else? Im new to Linux so step by step breakdowns would be nice
    – Dexsas
    Feb 23, 2021 at 7:54
  • Ok it’s extremely early posting this from my phone I will type up a complete guide when I get back from work. Feb 23, 2021 at 10:12
  • Ive already been answered but an explanation would still be nice thanks though
    – Dexsas
    Feb 23, 2021 at 12:47
0

Command line to override the content of /etc/apt/sources.list and solving the following error (error come from the line 4) see debian wiki: Sources.list :

E: Type 'new' is not known on line 4 in source list /etc/apt/sources.list
E: The list of sources could not be read. 

Open the terminal and paste the following lines:

cat <<-EOF |  sudo tee /etc/apt/sources.list
deb http://deb.debian.org/debian buster main
deb-src http://deb.debian.org/debian buster main

deb http://deb.debian.org/debian-security/ buster/updates main
deb-src http://deb.debian.org/debian-security/ buster/updates main

deb http://deb.debian.org/debian buster-updates main
deb-src http://deb.debian.org/debian buster-updates main
EOF

sudo apt update
sudo apt -y install android-tools-adb
1
  • Thanks M8 Do you know if this works with XAPKS too?
    – Dexsas
    Feb 23, 2021 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .