1

I'm using Devuan GNU/Linux 3 Beowulf. My machine has on-board audio (an Intel board). Audio used to work from most apps, including Chromium, but not including Firefox strangely enough (it wanted PulseAudio, and somehow that hadn't worked for me from the get-go).

Anyway, earlier today, I installed a package named debian-pulseaudio-config-override:amd64. I didn't do this intentionally, it was somehow dragged in when I also installed these:

linux-image-5.10.0-0.bpo.3-amd64
linux-headers-5.10.0-0.bpo.3-amd64:amd64 (5.10.13-1~bpo10+1)
linux-kbuild-5.10:amd64 (5.10.13-1~bpo10+1, automatic)
linux-headers-5.10.0-0.bpo.3-common:amd64 (5.10.13-1~bpo10+1)

After this:

  • No app plays audio by default.

  • Audacious (for example) is able to play audio if I manually choose the card from this drop-down menu it offers me of ALSA outputs

  • My Cinnamon system settings panel's Sound device configuration dialog only shows other output devices: HDMI and Digital SPDIF.

  • vlc manages to find the proper audio output device by default, somehow (but not the appropriate mixer device; although it wasn't finding it earlier, either).

  • aplay -l shows the on-board audio :

    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    ... snip ...
    

What can I do to re-enable audio playback?

2

1 Answer 1

0

Somehow, installing the debian-pulseaudio-config-override package makes all audio go through the PulseAudio server. Now, in PulseAudio, the choice of default audio output device was wrong - it was one of the HDMI connections. That should really not have happened, since I don't have an audio-capable monitor, but - it did (perhaps because of loading the v4l2loopback module).

So, what I did is start pavucontrol - The PulseAudio configuration utility, which looked like this:

enter image description here

and I changed the Built-In Audio option. There are a zillion configurations, and I had to do some trial-and-error, but "Analog Surround Sound 5.1 Output + Analog Stereo Input (unplugged)" gives me what I need.

Note: I'm not saying this will work for everyone in every situation - Linux audio is finicky and brittle in my experience :-(

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .