0

I have installed openldap from symas on centos 8,

  • I modified /etc/openldap/slapd.d/cn=config/olcDatabase={2}mdb.ldif by adding the following

    olcRootPW: {SSHA}......etc line to make a password

  • modified the slapd configuration file to be :

    **BASE    dc=example**
    
    **URI     ldap://localhost:389**
    
  • added the following file :

SampleOrganization.ldif

dn : dc=example

objectclass : domain

dc : example

dn : ou=Accountants,dc=example

objectClass : organizationalUnit

ou : Accountants

dn : ou=Engineers,dc=example

objectClass : organizationalUnit

ou : Engineers

on the terminal I run :

ldapadd -x -c -W -D "cn=Manager,dc=my-domain,dc=com" -H ldap://localhost:389 -f SampleOrganization.ldif

Then entered the password ... it seems the object is added because no error appeared

Now the problem when trying to search nothing is retrieved using :

ldapsearch -W -D "cn=Manager,dc=my-domain,dc=com" -H ldap://127.0.0.1:389 -b "ou=Engineers,dc=example" "Smith"


I would like to mention after some search i tried slapcat it gave the following Error :

6031b551 ldif_read_file: checksum error on "/etc/openldap/slapd.d/cn=config/olcDatabase={0}config.ldif"
6031b551 ldif_read_file: checksum error on "/etc/openldap/slapd.d/cn=config/olcDatabase={2}mdb.ldif"
6031b551 The first database does not allow slapcat; using the first available one (2)

I am so much confused what could be the reason for that i have some doubt it may be the checksum error but if so how to fix it?

nothing is retrieved giving the following :

# extended LDIF
#
# LDAPv3
# base <dc=example> with scope subtree
# filter: (objectclass=*)
# requesting: ALL
#

# search result
search: 2
result: 32 No such object

# numResponses: 1

1 Answer 1

0

I modified /etc/openldap/slapd.d/cn=config/olcDatabase={2}mdb.ldif

The files of back-config are not edited like regular text files. You have to use ldapadd, ldapmodify to send LDAP write operations for modifying the config.

6031b551 ldif_read_file: checksum error on

This is the result of manually modifying LDIF files of back-config.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .