1

Laptop: Thinkpad E14 Gen 2 AMD Ryzen 5 4500U BIOS: latest 1.10 OS: Ubuntu 18.04.5

My laptop boots properly when I use the default 5.4.65 kernel but when I try to update the kernel(tried 5.8.5, 5.8.10, 5.10.0,5.11.0) Ubuntu doesnt boot. I get the following error:

error message with quiet option error message with verbose option verbose after disabling snap after snd blacklist

2
  • Looks essentially the same as this question on AskUbuntu. Unfortunately that one has no answers either. But those latest errors seem to be about USB Type-C power management by ACPI, so not necessarily fatal. Check the kernel boot options in your bootloader: if they include quiet, remove that for one attempt. If there is no quiet, add verbose instead. That should result in a lot more messages describing all the steps of the boot procedure, and that should give better clues on what is actually stopping the boot process. – telcoM Feb 20 at 9:28
  • @telcoM I tried the verbose option , i.stack.imgur.com/ovHiq.jpg Is there a way print this errors from a file while booting through my 5.4.65 working kernel? – concorde42 Feb 20 at 10:05
4

There are issues with AMD's virtualization subsystem under newer Linux kernels (>= 5.5) that are essentially implementation issues, which is to say that in your case, the ultimate solution for the issue should come from Lenovo in the form of a BIOS update which corrects the manner in which the Ryzen virtualizations are initialized.

Of course that does nothing to solve your issue in the here and now, so until then you'll need to find the correct kernel command line parameters that will disable or degrade the virtualization subsystem to a point where the boot process is able to continue past it with at most an error, as opposed to a panic. I don't have any Ryzen systems so I can't offer much certainty, but I believe you'll need to add one of the follows sets of parameters to your kernel command line:

  • iommu=soft
  • iommu=soft pci=noaer
  • amd_iommu_intr=legacy iommu=soft
  • amd_iommu=off iommu=off
  • amd_iommu=off iommu=off amdgpu.noretry=0 nox2apic
  • acpi=off

I'm afraid these sorts of issues are most often resolved with this sort of trial and error approach to discover what works for your particular hardware setup. Assuming you're booting using GRUB, you would test these extra parameters by pressing the E key on your keyboard after highlighting the kernel entry you wish to boot, find the line of the boot script that begins with linux (it's often indented from the left margin) and add these extra parameters to the end of the line. Then press Ctrl + X to boot using the edited kernel command line and cross your fingers. Once you find a combination that allows the system to boot successfully, you would make those new parameters permanent by editing the file /etc/default/grub and placing them at the end of the line starting with GRUB_CMDLINE_LINUX_DEFAULT, inside the closing quotation mark.

Depending on your need for hardware virtualization, another more straightforward approach would be to enter your UEFI BIOS settings by repeatedly tapping the F1 key on your keyboard at two second intervals immediately after powering it on, until the BIOS Settings are displayed, and looking for the entry containing "AMD" and "Virtualization" in the name and switching its value to "Off" or "Disabled". You could then wait for the next UEFI BIOS release for your system (the current version is 1.10, released 2021-01-25) and try re-enabling the virtualization setting after the update is successful.

3
  • I tried all the combinations of the boot parameters and disabled amd VT in bios, it still doesnt boot. – concorde42 Feb 20 at 11:20
  • @concorde42 I'm sorry I wasn't able to help solve your issue. I honestly don't know what it could be, but I'll keep pondering on it and maybe some inspiration will strike. A couple more parameters you could try would be pci=noacpi or perhaps acpi=strict, but those are shots in the dark. Where are you getting your kernel packages? Are they Ubuntu Mainline builds? The full contents of the default kernel cmdline parameters would be helpful too. – Peter J. Mello Feb 20 at 13:36
  • Thanks for taking the time to help me I used this script: github.com/pimlie/ubuntu-mainline-kernel.sh to update the kernel...could this be the issue? Default kernel cmdline parameters: ro verbose splash $vt_handoff – concorde42 Feb 20 at 13:46
0

It looks to me you've got troubles not with the new kernels but with userspace. Kernel messages between boots are different and not indicative of any freeze.

At same time the last systemd message looks suspicious and confusing: mounting gnome-calculator? Really? If I were you I'd try to remove all installed snaps under the kernel which still works and try again.

12
  • Should I disable snap ? Which files should I delete? – concorde42 Feb 20 at 16:39
  • I removed snap it still doesn't boot. Got any other pointers for me? – concorde42 Feb 21 at 5:03
  • Try booting with verbose (remove quiet as well) again and upload a picture. – Artem S. Tashkinov Feb 21 at 7:54
  • 1
    Just tried with 5.10.17 and 5.11, does not work. A thing to note is that 5.11 doesn't show the error messages like the other kernels, but it is still stuck on Starting Plymouth! Guess I will file a bug report. Thanks for all the help. – concorde42 Feb 22 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.