1

I would like to run QHD (2560x1440) resolution with the above setup (under Fedora 33, nvidia 390.141) via DVI output (connected via a DVI KVM-Switch and a DVI-HDMI adapter), but ran into problems because of conflicting EDID information. (I might add, that the same config works under Windows 10 with a GT610)

During X startup, I see:

[  1246.824] (--) NVIDIA(GPU-0): Philips PHL 275E1 (DFP-0): connected
[  1246.824] (--) NVIDIA(GPU-0): Philips PHL 275E1 (DFP-0): Internal TMDS
[  1246.824] (--) NVIDIA(GPU-0): Philips PHL 275E1 (DFP-0) Name Aliases:
[  1246.824] (--) NVIDIA(GPU-0):   DFP
[  1246.824] (--) NVIDIA(GPU-0):   DFP-0
[  1246.824] (--) NVIDIA(GPU-0):   DPY-2
[  1246.824] (--) NVIDIA(GPU-0):   DVI-I-1
[  1246.824] (--) NVIDIA(GPU-0):   DPY-EDID-d8924ab7-3fc5-1d05-8925-b0246b2fb6b2
[  1246.824] (--) NVIDIA(GPU-0):   DVI-I-1
[  1246.824] (--) NVIDIA(GPU-0): Philips PHL 275E1 (DFP-0): 230.0 MHz maximum pixel clock

and

[  1246.824] (--) NVIDIA(GPU-0): --- EDID for Philips PHL 275E1 (DVI-I-1) ---
[  1246.824] (--) NVIDIA(GPU-0): EDID Version                 : 1.3
[  1246.824] (--) NVIDIA(GPU-0): Manufacturer                 : PHL
[  1246.824] (--) NVIDIA(GPU-0): Monitor Name                 : Philips PHL 275E1
[  1246.824] (--) NVIDIA(GPU-0): Product ID                   : 0xc20c
[  1246.824] (--) NVIDIA(GPU-0): 32-bit Serial Number         : 0x0000a609
[  1246.824] (--) NVIDIA(GPU-0): Serial Number String         : 
[  1246.824] (--) NVIDIA(GPU-0): Manufacture Date             : 2020, week 51
[  1246.824] (--) NVIDIA(GPU-0): DPMS Capabilities            : Active Off
[  1246.824] (--) NVIDIA(GPU-0): Input Type                   : Digital
[  1246.824] (--) NVIDIA(GPU-0): Prefer first detailed timing : Yes
[  1246.824] (--) NVIDIA(GPU-0): Supports GTF                 : No
[  1246.824] (--) NVIDIA(GPU-0): Maximum Image Size           : 600 mm x 340 mm
[  1246.824] (--) NVIDIA(GPU-0): Valid HSync Range            : 30.0 kHz - 114.0 kHz
[  1246.824] (--) NVIDIA(GPU-0): Valid VRefresh Range         : 48.0 Hz - 75.0 Hz
[  1246.824] (--) NVIDIA(GPU-0): EDID maximum pixel clock     : 300.0 MHz

As a consequence, X sorts out the detailed timings for 2560x1440 provided by EDID:

[  1246.826] (II) NVIDIA(GPU-0): --- Building ModePool for Philips PHL 275E1 (DFP-0) ---
[  1246.826] (WW) NVIDIA(GPU-0):   Validating Mode "2560x1440_60":
[  1246.826] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[  1246.826] (WW) NVIDIA(GPU-0):     2560 x 1440 @ 60 Hz
[  1246.826] (WW) NVIDIA(GPU-0):       Pixel Clock      : 241.50 MHz
[  1246.826] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 2560, 2608
[  1246.826] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 2640, 2720
[  1246.826] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 1440, 1443
[  1246.826] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 1448, 1481
[  1246.826] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H +V 
[  1246.826] (WW) NVIDIA(GPU-0):     Mode is rejected: PixelClock (241.5 MHz) too high for
[  1246.826] (WW) NVIDIA(GPU-0):     Display Device (Max: 230.0 MHz).
[  1246.826] (WW) NVIDIA(GPU-0):     Mode "2560x1440_60" is invalid.

Any idea what I can do about this?

1 Answer 1

0

After some more research, it looks like the card I have is an older version of the GT 730, which is only supported by the 390.x version of the nvidia drivers.

Manually adding

Option "ModeValidation" "DFP-0: AllowNonEdidModes,NoMaxPClkCheck"

in /etc/X11/xorg.conf only lead to a very blurry version of that resolution.

I switched to a GT 710(!), which is supported by the newer nvidia drivers (455.x.y & 460.x.y) and everything works now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .