5

I'm having issues with scaling on Wayland with Fedora 33 (Radeon 6900 XT, kernel 5.10.15-200). I've got double 4k 27" monitors.

Scaling changes the size of UI components correctly, so setting it to 200% in gnome settings makes everything appear twice as big, but most of the programs I'm using detects scaled resolution (UHD/2 = FHD) but not the scaling factor (2x).

Effect of this is that a program is rendered in FHD instead of UHD and it makes it blurry to display on UHD monitor. I've run through the ArchWiki for HiDPI but nothing seems to work. Below is a screenshot that compares font rendering of Firefox and Visual Studio. Most of the programs I'm using are blurry with wayland scaling (e.g. Visual Studio, Android Studio, Slack, Mailspring)

Any known way to solve it or people using wayland with HiDPI are not bothered with blurrines?

Visual Studio macro screenshot with 200% scaling - Blurry Firefox macro screenshot with 200% scaling - Not blurry

1 Answer 1

2

Visual Studio Code (and other electron apps, like e.g. Slack desktop app)

It runs under the XWayland compatibility layer. To opt out, start the application with the following command line switches (v1.56 april 2021 and above).

-enable-features=UseOzonePlatform --ozone-platform=wayland

Android Studio (and other JetBrains IDEs like IntelliJ, Webstorm, Rider etc)

Java still has no native Wayland support, so you are stuck on XWayland. There is Project Wakefield, though. JetBrains has set the goal to support wayland natively, and is contributing to Wakefield actively .

Until this succeeds, you have to stick to the workarounds stated in their known issues:

  • switch off fractional scaling
  • go back to using "pure" X session without Wayland

Edit: find more fine tuning in the Arch Wiki

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.