1

I'm quite new to gentoo. When booting my gentoo operating system it gets stuck on

pci 0000:01:00.0: vgaarb: VGA device added: decode=io+mem,owns=io+mem,locks=none

my first reflex was that this is a mistake in my kernel config with the graphics drivers but I couldn't find the problem there. I undid some of my kernel changes now: I changed the amount of GPU's from 2 back to 16, I now get another error message,

radeon 0000:01:00.0: remove _conflicting_pci_framebuffers: bar2: 0xe4000000 -> 0xe400ffff

why would this change when updating the number of GPU's? I thought that 2 was enough (1 for integrated graphics and 1 for my GPU)

My laptop has a Intel Pentium U4100 and an ATI radeon HD 4330 graphics card

Thanks anyway

5
  • Is it a clean installation? How did you create your kernel .config? Did you use genkernel in running Gentoo live? There are many things that could go wrong if you configured your kernel manually.
    – BlueManCZ
    Feb 15 at 11:10
  • @BlueManCZ It was indeed a clean installation, I created the .config as in the handbook: make && make modules_install , then make install. I did my installation throught ubuntu. I did not use genkernel. Feb 15 at 11:15
  • @BlueManCZ If there are so many things that could go wrong, would you reccomend going back to the default kernel settings? I did spend some time poking around in the kernel settings so it probably is a problem there. maybe I should first look for a running os and then start optimizing it. Feb 15 at 11:21
  • Yes, exactly as you said. Start with genkernel and working configuration. Then before each change you backup latest working .config, make few edits, compile the kernel again and check if it works. If not, you know exactly what went wrong and you can revert your saved .config.
    – BlueManCZ
    Feb 15 at 12:04
  • @BlueManCZ Thank you for your time, Feb 15 at 12:11
0

I got it up and running, for me the genkernel didn't work, If I went in my Kernel I disabled my ATI Radeon And the laptop hybrid graphics under ---> Devices ---> Graphics

It might be one of the two or both. When I find wich one it is I will update this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.