I'm working on a simple bash script that should be able to run on Ubuntu and CentOS distributions (support for Debian and Fedora/RHEL would be a plus) and I need to know the name and version of the distribution the script is running (in order to trigger specific actions, for instance the creation of repositories). So far what I've got is this:

OS=$(awk '/DISTRIB_ID=/' /etc/*-release | sed 's/DISTRIB_ID=//' | tr '[:upper:]' '[:lower:]')
ARCH=$(uname -m | sed 's/x86_//;s/i[3-6]86/32/')
VERSION=$(awk '/DISTRIB_RELEASE=/' /etc/*-release | sed 's/DISTRIB_RELEASE=//' | sed 's/[.]0/./')

if [ -z "$OS" ]; then
    OS=$(awk '{print $1}' /etc/*-release | tr '[:upper:]' '[:lower:]')
fi

if [ -z "$VERSION" ]; then
    VERSION=$(awk '{print $3}' /etc/*-release)
fi

echo $OS
echo $ARCH
echo $VERSION

This seems to work, returning ubuntu or centos (I haven't tried others) as the release name. However, I have a feeling that there must be an easier, more reliable way of finding this out -- is that true?

It doesn't work for RedHat. /etc/redhat-release contains : Redhat Linux Entreprise release 5.5

So, the version is not the third word, you'd better use :

OS_MAJOR_VERSION=`sed -rn 's/.*([0-9])\.[0-9].*/\1/p' /etc/redhat-release`
OS_MINOR_VERSION=`sed -rn 's/.*[0-9].([0-9]).*/\1/p' /etc/redhat-release`
echo "RedHat/CentOS $OS_MAJOR_VERSION.$OS_MINOR_VERSION"
  • Are you sure +-release works? Effectively you're looking assuming it will be /etc/lsb-release, so perhaps just call it that. – Mikel Jan 24 '11 at 5:57
  • @Mikel: I replaced * with + to avoid the comment formating, it should be etc/*-release, it seems to work. – Alix Axel Jan 24 '11 at 6:20
  • 7
    Never introduce a syntax error to get formatting right. Besides, the formatting is wrong only in the preview, the final view picks up the syntax from the tags. – Gilles Jan 24 '11 at 21:07
  • Why no one mention this f.e. uname -rv | grep -i "name_of_distro" and use exit code? – fugitive Feb 6 '17 at 14:21

18 Answers 18

up vote 163 down vote accepted

To get OS and VER, the latest standard seems to be /etc/os-release. Before that, there was lsb_release and /etc/lsb-release. Before that, you had to look for different files for each distribution.

Here's what I'd suggest

if [ -f /etc/os-release ]; then
    # freedesktop.org and systemd
    . /etc/os-release
    OS=$NAME
    VER=$VERSION_ID
elif type lsb_release >/dev/null 2>&1; then
    # linuxbase.org
    OS=$(lsb_release -si)
    VER=$(lsb_release -sr)
elif [ -f /etc/lsb-release ]; then
    # For some versions of Debian/Ubuntu without lsb_release command
    . /etc/lsb-release
    OS=$DISTRIB_ID
    VER=$DISTRIB_RELEASE
elif [ -f /etc/debian_version ]; then
    # Older Debian/Ubuntu/etc.
    OS=Debian
    VER=$(cat /etc/debian_version)
elif [ -f /etc/SuSe-release ]; then
    # Older SuSE/etc.
    ...
elif [ -f /etc/redhat-release ]; then
    # Older Red Hat, CentOS, etc.
    ...
else
    # Fall back to uname, e.g. "Linux <version>", also works for BSD, etc.
    OS=$(uname -s)
    VER=$(uname -r)
fi

I think uname to get ARCH is still the best way. But the example you gave obviously only handles Intel systems. I'd either call it BITS like this:

case $(uname -m) in
x86_64)
    BITS=64
    ;;
i*86)
    BITS=32
    ;;
*)
    BITS=?
    ;;
esac

Or change ARCH to be the more common, yet unambiguous versions: x86 and x64 or similar:

case $(uname -m) in
x86_64)
    ARCH=x64  # or AMD64 or Intel64 or whatever
    ;;
i*86)
    ARCH=x86  # or IA32 or Intel32 or whatever
    ;;
*)
    # leave ARCH as-is
    ;;
esac

but of course that's up to you.

  • 2
    I would check for lsb_release and use it if available, but it isn't available everywhere. For instance, it isn't in the default install of Fedora 14. – Steven D Jan 24 '11 at 5:47
  • Really? Did you try spelling it with - and _? Maybe it's in /lib/lsb or somewhere like that. What does rpm -qa "lsb*" print? – Mikel Jan 24 '11 at 5:56
  • 1
    rpm -qa "lsb* prints nothing. According to yum provides */lsb_release it is contained in a package called redhat-lsb which I guess is not installed by default. However, I'm not a Fedora expert, these are just the results from a random Fedora VM I have and could be very wrong. – Steven D Jan 24 '11 at 6:01
  • 3
    Just installed Fedora 14 in a VM, and there is no lsb-release, as you said. – Mikel Jan 24 '11 at 6:07
  • 4
    Don't use $OS, $VERSION, etc -- by convention, we capitalize environment variables (PAGER, EDITOR, SHELL, ...) and internal shell variables (BASH_VERSION, RANDOM, ...). All other variable names should contain at least one lowercase letter. This convention avoids accidentally overriding environmental and internal variables. – Chris Down Sep 16 '11 at 20:18

I'd go with this as a first step:

ls /etc/*release

Gentoo, RedHat, Arch & SuSE have a file called e.g. /etc/gentoo-release. Seems to be popular, check this site about release-files.

Debian & Ubuntu should have a /etc/lsb-release which contains release info also, and will show up with the previous command.

Another quick one is uname -rv. If the kernel installed is the stock distro kernel, you'll usually sometimes find the name in there.

  • On Debian, that's uname -a. – Tshepang Mar 29 '11 at 20:31
  • 2
    doesn't uname -rv contain the info though? uname -a will print things like type of processor and hostname that are irrelevant here. (But both kernel release (-r) and version (-v) are necessary, not all distros do it the same there) – Mat Mar 29 '11 at 20:34
  • uname -r gives 2.6.32-5-686-bigmem and uname -v gives #1 SMP Tue Mar 8 22:14:55 UTC 2011 on Debian 6. uname -a OTOH gives Linux debian 2.6.32-5-686-bigmem #1 SMP Tue Mar 8 22:14:55 UTC 2011 i686 GNU/Linux. – Tshepang Mar 29 '11 at 22:22
  • the second part of uname -a is -n, i.e. nodename == hostname. so I'd say uname will not be interesting on Debian. Come to think of it, I'm not sure it is so useful on RedHat either. – Mat Mar 29 '11 at 22:26
  • Oh, ok. So it's just by luck that I set my hostname as default, debian. – Tshepang Mar 29 '11 at 22:29

lsb_release -a. Works on Debian and I guess Ubuntu, but I'm not sure about the rest. Normally it should exist in all GNU/Linux distributions since it is LSB (Linux Standard Base) related.

  • 3
    It's not installed by default on Gentoo. It wasn't by default on Fedora either at some point (probably is now though) – Mat Mar 29 '11 at 19:13
  • 2
    This worked on Debian squeeze, Fedora 14, and OpenSUSE 11.3. On Debian and SUSE the package containing lsb_release was lsb-release, on Fedora it was redhat-lsb. It was already installed on Debian and SUSE, but not on Fedora. I think this is the best answer so far. +1. – Faheem Mitha Mar 29 '11 at 20:09
  • 3
    lsb_release is not part of the CentOS 6 minimal install. – a coder Oct 8 '13 at 15:30
  • 1
    lsb_release -a returns "-bash: lsb_release: command not found" on Raspberry with Raspbian (Debian 7.1 derived). – Peter Mortensen Jun 5 '14 at 11:32
  • lsb_release -a works on Red Hat Enterprise Linux Server release 6.6 (Santiago) – jwilleke Jan 28 '15 at 13:56

One-liner, fallbacks, one line of output, no errors.

lsb_release -ds 2>/dev/null || cat /etc/*release 2>/dev/null | head -n1 || uname -om
  • Beautiful, thank you. Note this still doesn't work on Mac OS X, but it works fine on Ubuntu and CentOS (which are the three I have handy). – Wildcard Dec 23 '15 at 3:32
  • 1
    Brilliant! Why such a bueatiful answer not on the top? – Neo Mar 28 '17 at 2:08
  1. lsb-* isn't installed/doesn't exist on base CentOS or Debian systems
  2. /proc/* doesn't exist on OSX

Take a tip from javascript developers. Don't test for the version, test for the capability. It's not pretty, but it works. Expand as necessary.

function os_type
{
case `uname` in
  Linux )
     LINUX=1
     which yum && { echo centos; return; }
     which zypper && { echo opensuse; return; }
     which apt-get && { echo debian; return; }
     ;;
  Darwin )
     DARWIN=1
     ;;
  * )
     # Handle AmgiaOS, CPM, and modified cable modems here.
     ;;
esac
}  
  • 5
    Yum could very well be Red Hat, Scientific Linux, or Fedora. There was an apt command for Fedora mimiking Debian's. And so on. Just clasifying anything with yum as CentOS gives you a range of supported systems from Red Hat 4 to Fedora 18, that is some 8 years of Linux history right there. If you need to know if <foo> is supported, specifically check for <foo> instead of guessing based on (unreliable) distribution identification! Sure, it leads to something of the ilk of autotools, but that can't be helped (just thank $DEITY that the Unix wars are over). – vonbrand Jan 18 '13 at 3:21
  • @vonbrand indeed, it is as you say. i don't attempt to differentiate between sub-flavours. and the order i check in (hopefully) removes most tricky situations (RHEL with apt-get installed), although i didn't do a lot of research. if RHEL can have apt-get installed, and Ubuntu users have yum... well, you're just bang out of luck. – Orwellophile Jan 22 '13 at 2:40
python -c "import platform;print(platform.platform())"

In order of most probable success, these:

cat /etc/*version
cat /proc/version #linprocfs/version for FreeBSD when "linux" enabled
cat /etc/*release
uname -rv

cover most cases (AFAIK): Debian, Ubuntu, Slackware, Suse, Redhat, Gentoo, *BSD and perhaps others.

  • cat /etc/*version does not work (there is no such file) on CentOS (at least on 6.4) – om-nom-nom Oct 23 '13 at 12:32
  • If you run the command in a container, /proc/version will contain the HOST distribution version, and not the container distribution one. – Dereckson Mar 24 '15 at 20:14

For most modern Linux OS systems, the file /etc/os-release is really becoming standard and is getting included in most OS. So inside your Bash script you can just include the file, and you will have access to all variables described here (for example: NAME, VERSION, ...)

So I'm just using this in my Bash script:

if [ -f /etc/os-release ]
then
        . /etc/os-release
else
        echo "ERROR: I need the file /etc/os-release to determine what my distribution is..."
        # If you want, you can include older or distribution specific files here...
        exit
fi

If the file /etc/debian_version exists, the distribution is Debian, or a Debian derivative. This file may have a release number; on my machine it is currently 6.0.1. If it is testing or unstable, it may say testing/unstable, or it may have the number of the upcoming release. My impression is that on Ubuntu at least, this file is always testing/unstable, and that they don't put the release number in it, but someone can correct me if I am wrong.

Fedora (recent releases at least), have a similar file, namely /etc/fedora-release.

  • Newer Debian versions use /etc/os-release instead. – Dereckson Mar 24 '15 at 20:14
  • 1
    @Dereckson I checked my wheezy machine, and it has both /etc/debian_version and /etc/os-release. – Faheem Mitha Mar 24 '15 at 20:17
  • Tested in a Jessie chroot created with debootstrap. But indeed, a local machine also under Jessie, this time installed a more conventional way, contains a /etc/debian_version file. So the way we prepare a Debian installation could affect the available release files, that's interesting. – Dereckson Mar 28 '15 at 10:05
  • Debian's os-release does not include the full version number from debian_version. See unix.stackexchange.com/questions/382531 . – JdeBP Jul 29 '17 at 7:08

If you can't or don't want to use the LSB release file (due to the dependencies the package brings in), you can look for the distro-specific release files. Bcfg2 has a probe for the distro you might be able to use: http://trac.mcs.anl.gov/projects/bcfg2/browser/doc/server/plugins/probes/group.txt

2 ways from many:

1) use

lsb_release -a

I tested it on CentOS 5.5 and Ubuntu 10.04

the output for CentOS is:

LSB Version:    :core-3.1-ia32:core-3.1-noarch:graphics-3.1-ia32:graphics-3.1-noarch 
Distributor ID: CentOS
Description:    CentOS release 5.5 (Final)
Release:        5.5
Codename:       Final

and for Ubuntu is:

LSB Version:    :core-3.1-ia32:core-3.1-noarch:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID: CentOS
Description:    CentOS release 5.5 (Final)
Release:        5.5
Codename:       Final

2) enter the following command:

cat /etc/*-release

I tested it on CentOS 5.5 and Ubuntu 10.04, and it works fine.

  • lsb_release is not in CentOS 6 (the min install fwiw) – a coder Oct 8 '13 at 15:34
  • lsb_release -a returns "-bash: lsb_release: command not found" on Raspberry with Raspbian (Debian 7.1 derived). – Peter Mortensen Jun 5 '14 at 11:34
  • It looks like the Ubuntu output is accidentally the same as the CentOS output. – Ben Stern Sep 24 at 1:35

This script works on Debian, (may need some tweak on Ubuntu)

#!/usr/bin/env bash

echo "Finding Debian/ Ubuntu Codename..."

CODENAME=`cat /etc/*-release | grep "VERSION="`
CODENAME=${CODENAME##*\(}
CODENAME=${CODENAME%%\)*}

echo "$CODENAME"
# => saucy, precise, lucid, wheezy, squeeze

Here is my simple chech_distro version. ^^;

#!/usr/bin/env bash
check_distro2(){
    if [[ -e /etc/redhat-release ]]
    then
      DISTRO=$(cat /etc/redhat-release)
    elif [[ -e /usr/bin/lsb_release ]]
    then
      DISTRO=$(lsb_release -d | awk -F ':' '{print $2}')
    elif [[ -e /etc/issue ]]
    then
      DISTRO=$(cat /etc/issue)
    else
      DISTRO=$(cat /proc/version)
    fi
    }

    check_distro2
    echo $DISTRO

Without version, just only dist:

cat /etc/issue | head -n +1 | awk '{print $1}'
  • An answer from a year earlier by Yahya Yahyaoui said the same thing. Both of these answers were in fact addressed in 2011 in answers that have since been deleted. The reasons that they are wrong still apply. – JdeBP Jul 29 '17 at 6:56

This was tested on Ubuntu 14 and CentOS 7

cat /etc/os-release | grep "PRETTY_NAME" | sed 's/PRETTY_NAME=//g' | sed 's/["]//g' | awk '{print $1}'
  • @don_crissti How would you do it? – BsdHelper Nov 23 '15 at 1:18
  • sed -n -e '/PRETTY_NAME/ s/^.*=\|"\| .*//gp' /etc/os-release – cas Nov 23 '15 at 1:41
  • @cas Very nice! Adding that to my toolbox. Thank you for sharing. – BsdHelper Nov 24 '15 at 6:35

I find a good script from here which works for most of common linux dists:

#! /bin/bash
# return an awkable string consisting of
#    unix OS type, or
#    Linux dist, or
#    a long guess (based on /proc), or
#    no clue

giveUp () {
   echo "Unknown"
   exit 0
}

# keep this easily awkable, prepending an initial clue
versionGuess () {
   if [ -e /proc/version ]; then
      echo -n "Unsure "
      cat /proc/version
      exit 0
   fi
   return 1
}

# if we have ignition, print and exit
gotDist () {
   [ -n "$1" ] && echo "$1" && exit 0
}

# we are only interested in a single word "dist" here
# various malformations can occur; admin will have to code appropately based on output
linuxRelease () {
   if [ -r /etc/lsb-release ]; then
      dist=$(grep 'DISTRIB_ID' /etc/lsb-release | sed 's/DISTRIB_ID=//' | head -1)
      gotDist "$dist"
   fi

   dist=$(find /etc/ -maxdepth 1 -name '*release' 2> /dev/null | sed 's/\/etc\///' | sed 's/-release//' | head -1)
   gotDist "$dist"

   dist=$(find /etc/ -maxdepth 1 -name '*version' 2> /dev/null | sed 's/\/etc\///' | sed 's/-version//' | head -1)
   gotDist "$dist"

   return 1
}

# start with uname and branch the decision from there
dist=$(uname -s 2> /dev/null)
if [ "$dist" = "Linux" ]; then
   linuxRelease
   versionGuess
   giveUp
elif [ -n "$dist" ]; then
   echo "$dist"
   exit 0
else
   versionGuess
   giveUp
fi

# we shouldn't get here
giveUp
# done

I use screenfetch script utility:

enter image description here

This command works for Debian based and Redhat based distributions: Using tr filter, you convert the document to one-word-per-line format and then count the first line which contains the distribution name.

tr -s ' \011' '\012' < /etc/issue | head -n 1
  • The comments on the now-deleted answer from 2011 that said the same thing, still apply. As does the mis-placed answer, again now deleted, that said that /etc/issue did not contain a version or a name on zenwalk. This is an administrator-modifiable file containing a message presented to humans that has no guarantees of containing anything that can be pulled out programatically. – JdeBP Jul 29 '17 at 6:54

protected by chaos Jan 26 '16 at 10:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.