I recently flashed my SD card to format and reinstall Linux Mint on my machine. Everything went well, but I have learned that SD cards cannot be use as a boot device.

The problem now is that I am trying to format the SD Card to use again as storage device in my camera, following this tutorial.

I want to format to FAT32 in order to use it every system, according to the instructions.

When I run the command sudo parted /dev/sdc --script -- mklabel msdos I get the following:

Error: Partition(s) on /dev/sdc are being used.

I checked permissions using ls -l /dev/sdc and got:

brw-rw---- 1 root disk 8, 32 Feb 14 03:25 /dev/sdc

Changed permissions with chmod 777 /dev/sdc and remade the first step, and cannot access the SD card to clean it.

I don't know what the "b" means as a permission... is it related to bootable?

I just installed Linux Mint Mate 20.1 and when I insert the SD Card it keeps showing the drive name as Linux Mint MATE 20.1 64-bit Any help would be great.


1 Answer 1


The "b" in the output from ls means it's a block device (also check this answer, not a normal file. If the volume shows up when you insert it, it means it is automounted. You can see it with df | grep sdc or mount | grep sdc. You need to unmount it (possibly as root) before being able to mangle with it. Try

umount /dev/sdc1


sudo umount /dev/sdc1

(sdc1 depends on what df or mount show)

  • findmnt is better than mount at listing mount-points. Feb 14, 2021 at 9:58
  • Thanks a lot Nicola! I used df | grep sdc and followed the sudo umont /dev/sdc accordingly, after that followed the tutorial I mentioned and everything worked fine. For the record, when I inserted the SD Card back into my Nikon D3200 it was not able to identify it. I update the date and time on Camera Menu and everything worked just fine. Thanks a lot once again. Feb 14, 2021 at 15:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .