0

So, I'm running a container that is showing this in the log:

WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.

Spending most of my life in Windows I'm about 80% Linux ignorant, and as far as I can tell, when setting this setting it does it system wide, which will also affect all the other containers. Do I want to do this?

Is there some way to set this for only the container that is recommending it? I should add in case it helps, that I'm running docker desktop in WSL2 mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.