1

I want to preface this by saying that I understand RPM-Fusion exists and that it has a way to install Nvidia drivers.

But, I am using Nvidia's cuda repo instead because I am interested in development rather than playing games (which is what my Windows computer on the remote controlled display switch is for). Unfortunately, Windows is a very difficult platform for development compared to Unix-based OS's:

https://developer.download.nvidia.com/compute/cuda/repos/fedora33/x86_64

From there, I have installed Nvidia's drivers (and Cuda drivers) via yum repo and dnf, but it appears as if Nvidia is not yet enabled. I trust Nvidia to deliver working Nvidia code, but it seems they missed something when it comes to working Linux packages -- that is fine.

But, there is some bit that needs to be set in some boot configuration somewhere to activate the installed Nvidia drivers.

This is getting back into the weeds and revisiting the manual installation process with grubby, gdm and Fedora (which is now obfuscated by the RPM-Fusion installation content).


The question is thus: what are the manual boot configuration settings that need to be adjusted to enable an installed Nvidia driver? (I have already disabled, blacklisted and removed Nouveau)

1 Answer 1

3

Edit /etc/sysconfig/grub and append rd.driver.blacklist=nouveau to end of GRUB_CMDLINE_LINUX=”…”.

## Example row with Fedora 33 BTRFS ##
GRUB_CMDLINE_LINUX="rhgb quiet rd.driver.blacklist=nouveau"

## OR with LVM ##
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet rd.driver.blacklist=nouveau"

Then update the grub2 conf

## BIOS ##
grub2-mkconfig -o /boot/grub2/grub.cfg

## UEFI ##
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
1
  • I'll try this in a few hours thanks man
    – Chris
    Commented Feb 11, 2021 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .