I noticed that some applications use the Adwaita Dark theme, while others use the light one. Is there a way to make all applications use the Dark one?

  • 1
    Adding screenshots or at least mentioning what applications are having this issue, would be helpful.
    – lmcanavals
    Feb 1 '13 at 18:35
  • According to gnome-session --version, I have Gnome, but as I use OpenBox as WM (are you using Metacity?), instead of the solution below, I use obconf to change theme (and set other preferences). Feb 1 '13 at 20:37

Replacing the main theme with the dark one in /usr/share/themes is not an ideal solution as each time gnome-themes is updated your theme will revert to default. It's preferable to properly configure your user account to use the dark theme, that way your settings will be preserved between updates. You can do that:

  • Manually: create (open if already present) the following file:


    edit like this:


  • Via gnome-tweak-tool (which essentially does the same thing as above, writing the same file):

    GNOME3 dark theme mode switch in gnome-tweak-tool

GTK2 Problem

This answer is indeed the ideal and "safe" (i.e no need to replace/mod any system files) method. However, currently neither this method nor Jeff's answer works for all apps. Coz only GNOME3/GTK3 has support for the dark theme mode. As of now, there are still many apps (for example those written in GNOME2/GTK2, Qt, wxWidgets, Java, etc) which don't use GTK3 and remain on the old GTK2 theming. To make those apps dark, replacing/modding the GTK2 part($ACTIVE_THEME/gtk-2.0/gtkrc) of the currently active theme works. To know more, see the answer to "Firefox not affected by gtk theme".

As GTK2 is deprecated and superseded by GTK3, all actively developed GTK2 apps are getting ported to or replaced by GTK3. Sooner or later, other toolkits like Qt, wxWidgets, etc may also implement support for GTK3. By that time, this method may become valid for all(maybe almost all) apps.

  • I haven't tested this, so I'm giving you the benefit of the doubt :) This does seem neater.
    – Jeff
    Apr 5 '13 at 0:53
  • My version of gnome-tweak-tool (updated AFAIK) doesn't have this option. Manually adding that file works fine after reboot.
    – Jeff
    Jun 14 '13 at 0:40
  • 3
    This does not work for all applications, e.g. Firefox. I'm going to try this now: askubuntu.com/questions/337018/…
    – Rasmus
    Nov 1 '13 at 1:14
  • 1
    I found using this theme worked quite well - I replaced the original Adwaita theme in /usr/share/themes with it and it works quite well :)
    – Wilf
    Apr 24 '15 at 20:30
  • For GTK+ 2, install the package gnome-themes-standard, then select its Adwaita-dark as your system theme. Having a separate name means this can point GTK+ 2 at a port of Adwaita:dark from GTK+ 3 to GTK+ 2. Sep 17 '17 at 19:36

Simply replace the main theme with the dark one (in a special copy of Adwaita in your home dir):

mkdir -p ~/.themes
cp -r /usr/share/themes/Adwaita ~/.themes/Darkwaita
cd ~/.themes/Darkwaita/gtk-3.0
cp gtk-dark.css gtk.css

Then use a tool like gnome-tweak-tool to set Darkwaita as your gtk theme, and the changes should take effect immediately.

  • Although it work, after an update it could be revert to the default. Nov 11 '13 at 22:56
  • That issue can be avoided by copying the theme into your home directory first: cp -r /usr/share/themes/Adwaita ~/.themes/Darkwaita; cp ~/.themes/Adwaita/gtk-3.0/gtk{-dark,}.css and then using gnome-tweak-tool to select Darkwaita theme.
    – robru
    Nov 2 '14 at 22:40
  • 4
    This no longer works in Ubuntu Vivid, the there is no longer a gtk-dark.css file and the full content of gtk.css is just /* Adwaita is the default theme of GTK+ 3, this file is not used */ so... fuck.
    – robru
    Mar 13 '15 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.