1

I am trying to mount nvme /dev/nvme0n1 to /mnt/chroot

I have created the directory /mnt/chroot

when I "sudo mount /dev/nvme0n1 /mnt/chroot" I get "mount: /mnt/chroot: /dev/nvme0n1 already mounted or mount point busy."

I have tried on an arch live usb and now on a Fedora 30 live usb.

findmnt /dev/nvme0n1

returns nothing meaning nvme0n1 is not mounted. But how can the mount point be busy if I just created the mount directory /mnt/chroot and nvme0n1 is not mounted?

My objective is to build chroot with root, /sys, /proc, /boot and /boot/efi mounted.

I'm weak on the cli for this task.

lsblk -f

NAME            FSTYPE            LABEL                     UUID                                   FSAVAIL FSUSE% MOUNTPOINT
loop0           squashfs                                                                                          
loop1           ext4              Anaconda                  b44431ef-901f-4c18-9b7b-224b8bb98af6                  
├─live-rw       ext4              Anaconda                  b44431ef-901f-4c18-9b7b-224b8bb98af6    822.1M    87% /
└─live-base     ext4              Anaconda                  b44431ef-901f-4c18-9b7b-224b8bb98af6                  
loop2                                                                                                             
└─live-rw       ext4              Anaconda                  b44431ef-901f-4c18-9b7b-224b8bb98af6    822.1M    87% /
sda                                                                                                               
├─sda1          vfat                                        1078-26A1                                             
├─sda2          xfs                                         7d8928c4-baa1-4eaa-a13c-e937031f8dfa                  
└─sda3          LVM2_member                                 OjAFDa-Il7s-Vj0h-Lian-culw-97um-9GYjOo                
  ├─centos-swap swap                                        df903e75-89f5-4646-aad1-981f17e032e9                  [SWAP]
  ├─centos-home xfs                                         c3dea145-a219-4896-ae9f-8419f91a13aa                  
  └─centos-root xfs                                         66a1a58a-c06f-4407-8d47-1fd4266c6b75                  
sdb             ext4              ssd2                      0be3be76-a16d-4777-ab09-c7cc372ed1bc                  
└─sdb1          ext4              ssd2                      c90f13b9-f228-4051-a586-7b6083f50105                  
sdc             linux_raid_member orcacomputers.orcainbox:0 4ca9118c-3a55-7d0f-db72-3ff2e8b9a521                  
└─md127         ext4                                        d52b3913-2ed2-4142-9309-3fdf641141f0                  
sdd             linux_raid_member orcacomputers.orcainbox:0 4ca9118c-3a55-7d0f-db72-3ff2e8b9a521                  
└─md127         ext4                                        d52b3913-2ed2-4142-9309-3fdf641141f0                  
sde             linux_raid_member orcacomputers.orcainbox:0 4ca9118c-3a55-7d0f-db72-3ff2e8b9a521                  
└─md127         ext4                                        d52b3913-2ed2-4142-9309-3fdf641141f0                  
sdf             iso9660           ARCH_202010               2020-10-01-15-07-58-00                                
├─sdf1          iso9660           ARCH_202010               2020-10-01-15-07-58-00                       0   100% /run/media/liveuser/ARCH_202010
└─sdf2          vfat              ARCHISO_EFI               137A-1EE8                                             
sdg             iso9660           Fedora-WS-Live-30-1-2     2019-04-26-02-34-40-00                                
├─sdg1          iso9660           Fedora-WS-Live-30-1-2     2019-04-26-02-34-40-00                       0   100% /run/initramfs/live
├─sdg2          vfat              ANACONDA                  E385-716D                                             
└─sdg3          hfsplus           ANACONDA                  8f5370e2-fd7c-3f3a-9d01-aa72345be183                  
sr0                                                                                                               
nvme0n1                                                                                                           
├─nvme0n1p1     LVM2_member                                 CjuOUt-h2bH-EjCp-ALwd-c8BW-ZckJ-cpB322                
├─nvme0n1p2     LVM2_member                                 M1em0l-TY0y-ZuIt-DK2i-0yJp-OHNz-7RfupC                
│ └─nvmeVg-var  ext4                                        3985016b-fa34-44ca-96ad-7c2e5d5f8221                  
├─nvme0n1p3     LVM2_member                                 qkaPsI-FLzs-wt4Y-bnhm-BpGK-aOcR-fheulP                
│ ├─nvmeVg-var  ext4                                        3985016b-fa34-44ca-96ad-7c2e5d5f8221                  
│ ├─nvmeVg-home ext4                                        540c7358-e018-43bc-b692-6e2398911b38                  
│ └─nvmeVg-root ext4                                        6f9437cd-c9af-4f88-a9b4-7d98e46979aa                  
├─nvme0n1p4     LVM2_member                                 CTkIFV-Ebvf-Ps5w-rysY-s7U0-VLhs-6jLVRV                
│ └─nvmeVg-home ext4                                        540c7358-e018-43bc-b692-6e2398911b38                  
├─nvme0n1p5     LVM2_member                                 Sjii2Q-zkwB-9Nhb-0g6o-4rt3-O9gy-4CMtEI                
│ └─nvmeVg-home ext4                                        540c7358-e018-43bc-b692-6e2398911b38                  
├─nvme0n1p6     LVM2_member                                 QLUYbk-TzNY-RZHz-ck60-gbqA-kPtk-QT2Tm4                
│ └─nvmeVg-root ext4                                        6f9437cd-c9af-4f88-a9b4-7d98e46979aa                  
├─nvme0n1p7     LVM2_member                                 nQg41G-8A3m-wMog-LBzJ-U09n-W1md-lgVEdQ                
│ └─nvmeVg-root ext4                                        6f9437cd-c9af-4f88-a9b4-7d98e46979aa                  
├─nvme0n1p8     LVM2_member                                 D5HOGp-nLA3-zypn-edIj-uPon-Pzrj-N6JcB5                
├─nvme0n1p9     LVM2_member                                 puKdcF-J2PT-THK1-nSqx-RMhe-98ZB-EnDPV0                
├─nvme0n1p10    LVM2_member                                 0XEQEc-pHGc-2B02-d4lp-581f-ZMYv-vKTgpG                
├─nvme0n1p11    LVM2_member                                 NF82AB-ZUaP-D9FF-PLVP-HMuA-pWFz-NIZFRG                
└─nvme0n1p12    ext4                                        3e5f9f87-3178-4ae3-bc51-f0f5134c5fb6          

df -h

Filesystem           Size  Used Avail Use% Mounted on
devtmpfs              32G     0   32G   0% /dev
tmpfs                 32G  4.0K   32G   1% /dev/shm
tmpfs                 32G  2.8M   32G   1% /run
tmpfs                 32G     0   32G   0% /sys/fs/cgroup
/dev/sdg1            1.9G  1.9G     0 100% /run/initramfs/live
/dev/mapper/live-rw  6.4G  5.6G  823M  88% /
tmpfs                 32G   76K   32G   1% /tmp
vartmp                32G     0   32G   0% /var/tmp
tmpfs                6.3G  3.5M  6.3G   1% /run/user/1000
/dev/sdf1            681M  681M     0 100% /run/media/liveuser/ARCH_202010
5
  • 1
    I've flagged the question because "please hold my hand while I step through an unfamiliar process" isn't really a question. There is plenty of documentation out there about how to build a chroot, so you'll need to go do some research and then come ask a question if you run into problems (and if no one has ever asked the question before). – cryptarch Feb 10 at 20:11
  • 1
    Edited for a question. I found your quotation useful. Thank you. – Jesse William Mac Dougall Feb 10 at 22:05
  • 1
    Mind if we have a look at output from lsblk -f and df -h? – cryptarch Feb 10 at 22:26
  • 1
    added. Do you get an update when I edit the post? thus making my "added" comment useless? – Jesse William Mac Dougall Feb 10 at 22:47
  • 1
    Nah, I only get notified about your comments, so you did good. I would probably be notified if I bookmarked the question (there's a little bookmark button). But I don't usually bookmark questions. – cryptarch Feb 10 at 23:22
1

nvme0n1 is a device, which contains partitions nvme0n1p1, nvme0n1p2 and so on.

You can mount only a filesystem, not a device with partitions on it.

1
  • So sda3-centos-root is where the OS is. So how do I mount that? "mount /dev/sda3 /mnt/anydirectory"? I have moved centos-home to the nvme0n1 – Jesse William Mac Dougall Feb 11 at 0:50
0

turns out sda was not mounted so I make a new directory and mounted to the new directory and it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.