0

I want to install a tar.gz file downloaded from here. I tried but I got an error.

I open the terminal in the folder and I'm trying to install.

Here is a screenshot of the file manager, showing part of the archive contents.

I have Debian 10.

enter image description here

1
  • 3
    What is this error you've mentioned? What have you done/tried so far? – BulletBob Feb 10 at 18:28
3

You'll need to extract three of the *.deb files out of the .tar.gz:

  • cpu-x_4.1.0+15.1_amd64.deb, the main program
  • cpuidtool_0.5.0_amd64.deb a tool used by the CPU-X program
  • libcpuid15_0.5.0_amd64.deb, a library used by the tool

The rest are debugging symbol files (-dbgsym) and development files (-dev); those are not needed for running the program, only for debugging it or using the libcpuid library in another programming project.

Once you have the the three files extracted, run this command in the directory you've placed them, as root:

apt install ./cpuidtool_0.5.0_amd64.deb ./libcpuid15_0.5.0_amd64.deb ./cpu-x_4.1.0+15.1_amd64.deb

...and that's it. The ./ in front of the package names is important: it tells apt to not try and find the named packages from a repository as normal, but use the package files you have right there.

After that, you should be able to run the program by either running the cpu-x command (as a regular user), or by finding the program in your GUI menus (System category, probably).

1
  • thanks a lot for your time and help, very appreciated. You are th best – James78 Feb 10 at 21:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.