1

I'm attempting to install the Dell openmanage tools on an ubuntu 20.04 docker container and I'm running into some issues.

Dell's provided guide:

echo 'deb http://linux.dell.com/repo/community/openmanage/950/focal focal main' | tee -a /etc/apt/sources.list.d/linux.dell.com.sources.list
gpg --keyserver pool.sks-keyservers.net --recv-key 1285491434D8786F
gpg -a --export 1285491434D8786F | apt-key add -
apt-get update
apt-get install srvadmin-all

When I run this I get the following error during the step to configure srvadmin-hapi:

Setting up srvadmin-hapi (9.5.0) ...
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
dpkg: error processing package srvadmin-hapi (--configure):
 installed srvadmin-hapi package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 srvadmin-hapi
E: Sub-process /usr/bin/dpkg returned an error code (1)

Full output of the apt-get install srvadmin-all command is here.


I've also tried downloading the individual package but I'm not sure if I can modify it in any way to not use systemd.

Is there any way for me to get this package to install on an ubuntu docker container?

1
  • It’s a shame the Dell packages don’t use Debian’s systemd support for pre-installation service policies (which is also available in Ubuntu), it would avoid this... Feb 12, 2021 at 14:11

1 Answer 1

2
+300

Create a /var/lib/dpkg/info/srvadmin-hapi.postinst with the following content:

#!/bin/bash
/bin/true

As said @jesse_b the srvadmin-hapi.postinst may be overwritten in the first attempt, consider modified it back again.

Then run:

sudo dpkg --configure -a
sudo apt install srvadmin-hapi

If the above instruction doesn't work, backup then edit the /var/lib/dpkg/status by removing srvadmin-hapi with its description then run:

sudo dpkg --configure -a
sudo apt install srvadmin-hapi
1
  • gpg --keyserver pool.sks-keyservers.net --recv-key 1285491434D8786F doesn't support anymore. I tried with sudo wget https://linux.dell.com/repo/pgp_pubkeys/0x1285491434D8786F.asc . Followed the step mentioned still it didn't work. I am seeing the same issue.
    – curiousguy
    Aug 5, 2021 at 11:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .