I'm running a headless VNC server (TigerVNC with Xfce). I need to increase the maximum allowed number of X clients because I'm hitting the 256 limit (yes I've got that many) and I get the "Maximum number of clients reached" error.

I read here that you can increase it either with the -maxclients option on the xserver or with the appropriate configuration in /etc/X11/xorg.conf.d/99-maxclients.conf. I don't think that applies to VNC though and I couldn't find any similar option for the vncserver command.

I tried to pass the -maxclients 512 option to startxfce4 in ~/.vnc/xstartup but it is ignored.

1 Answer 1


Well I actually tried the -maxclients option and... it worked!

It has to go on the vncserver command though, not on the window manager or in some X config file.

When started manually:

vncserver :1 -maxclients 512

When started via init.d:

update-rc.d vncserver defaults
vi /etc/default/vncservers
VNCSERVERARGS[1]="-maxclients 512"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .