0

I have an ASUS TUF B460 mobo with an i7 10400K CPU. I also have an EVGA GeForce GT 710. I have two HP ZR30w monitors capable of 2560x1600 each. I am not a gamer, I just want both monitors to be active, in full resolution, at the same time.

Running with the on-board graphics (before the EVGA adaptor), I could run one monitor at 2560x1600, but the other one only at 1280x800 (connected via DisplayPort and DVI). Once I installed the EVGA adaptor, though it has two DVI connectors on it, only one is Dual Link and I can run one monitor at 2560x1600, but the other runs at 1280x800.

Moving the second monitor back to the mobo, which ran it at 2560x1600 before I installed the extension adaptor, the monitor no longer comes up/runs at all no matter whether I choose DVI, DisplayPort or HDMI from the mobo.

I have tried with just the drivers that came with Linux Mint 20.4 and also with downloaded NVIDIA drivers, but it's as if with the EVGA, the mobo's graphics are not available.

On my last machine, I had an EVGA GeForce GT 730 with two DVI connectors and both happened to support Dual Link. (And, I didn't need the mobo's graphics.) For 6 years I was happy with these monitors, but I can no longer get that card.

My question is whether or not I can expect to run both solutions simultaneously. I am not like those who want to switch between gaming on the extension adaptor and running otherwise on their on-board graphics for everything else to save on battery. This is a desktop and I need both monitors running (to support development environments, e-mail, browsing, Slack, etc., etc. open all the time).

1 Answer 1

1

Asus motherboards tend to disable the on-board graphics support when a GPU card is installed, by default. But this can be overridden in the BIOS settings.

Unfortunately it looks like Asus has simplified their motherboard manuals, and they no longer include a full description of the BIOS settings. But it might still be in the same location as in the Z390 generation of motherboards: in the BIOS settings, go to the Advanced mode, go to the "Advanced" menu, find "System Agent (SA) configuration" and under there, there should be "Multi-Monitor" or similar. Enable that, and now the Intel iGPU should activate along with the add-on GPU card.

1
  • This is a good answer. In my BIOS, I found exactly the steps outlined here. Only, there is no combination of changes to the graphics section of the System Agent configuration that results in both sets of graphics being active concurrently. Commented Feb 9, 2021 at 0:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .