Just installed Fedora 18 and I can't get the wireless to work.
What do I have and what have I done?

I have a Broadcom BCM4312 which is supported by the broadcom-wl driver. (link)

lspci | grep Network
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

I have installed the driver and the kernel modules for it:

rpm -qa | grep -e '-wl' | sort

The kernel:

uname -r

I have loaded the module

modprobe wl

lsmod | sort | grep wl
cfg80211              171182  1 wl
lib80211               13684  1 wl
wl                   2465403  0 

And even removed the ssb module, which I read on couple forums.
Restarted the service, and even rebooted:

service NetworkManager restart

After all these, the wireless card is still not visible. What am I missing?

  • 2
    Doesn't the (presumably included in your distribution) bm43 work? Third-party modules have a hang of being outdated with respect to the kernel, be of a code quality that causes eye cancer (say some kernel hackers), break horribly, or all of the above...
    – vonbrand
    Jan 31 '13 at 16:36
  • @vonbrand Originally it was installed but not working so I have removed it. I went back and removed and reinstalled b43fwcutter, b43-tools, and broadcom-wl and it got it now.
    – slybloty
    Jan 31 '13 at 17:23
  • @vonbrand I take that back. After doing so, sometimes it recognizes the wireless card and sometimes it doesn't. But it never connects to secured networks. It throws an activation of network connection failed message.
    – slybloty
    Jan 31 '13 at 18:41

I was originally running kernel 3.7.4-204.fc18.i686 with kmod-wl-3.7.4-204.fc18.i686- and the wireless had issues. After 2 more updates of the kernel it just works fine.

So this is what I have running and working good now:

sly@localhost ~$ uname -r
sly@localhost ~$ rpm -qa | grep -e '-wl' | sort
sly@localhost ~$ lsmod | sort | grep wl
cfg80211              171182  1 wl
lib80211               13684  2 wl,lib80211_crypt_tkip
wl                   2465403  0 

Try service NetworkManager stop. It will just interfere with any attempt to manual configure and debug the set-up.

Now try iwconfig. Hopefully you see mention of an interface that isn't described with "no wireless extensions". Presuming that is wlan0 (it could be something else), try:

ifconfig wlan0 up && iwlist wlan0 scanning

You should see some copious output detailing the detected wifi networks, which means your driver is working, or working well enough to scan. Which does not necessarily mean it is working well enough to be useful beyond this, but it probably is. The next step is to try configuring the interface to connect to a network...

  • Sometimes is says Interface doesn't support scanning : Invalid argument. Sometimes I can connect only to unsecured networks, but never to secured ones. And most of the times it finds no wireless interface. I don't know what to make of this.
    – slybloty
    Jan 31 '13 at 18:38
  • If "Doesn't support scanning" happens when ifconfig shows the interface is up, that doesn't sound good :( WRT networks, that chip is only good for b/g. If you haven't looked yet: linuxwireless.org/en/users/Drivers/b43
    – goldilocks
    Jan 31 '13 at 18:43
  • Funny thing is that it worked fine with Fedora 15 until I made the upgrade. It's scanning now, but I can't get it to assign the key to it. Error for wireless request "Set Encode" (8B2A) : SET failed on device eth0 ; Invalid argument.
    – slybloty
    Jan 31 '13 at 18:54
  • Kernel drivers can be like that, I guess. It sounds like a pretty old chip, if not many people are using it now under 3.0+ kernels then it may not have been noticed much when the driver broke. This is probably especially true if it is a third party driver written for 2.6, unfortunately.
    – goldilocks
    Jan 31 '13 at 19:01
  • 1
    Current Fedora fully updated? Did you use the Fedora driver or a third-party one before? Is there any way to check again with Fedora 15 (perhaps a LiveCD?) Just to rule out any breakage of the machine... Any change (other than the upgrade) that comes to mind? Consider checking/reporting at the Fedora bugzilla.
    – vonbrand
    Jan 31 '13 at 19:49

I had all these same problems on my HP mini 1001,

I found so many people having the same problems so i thought i would add my solution, my wireless connection is completely fine and working on fedora 18. wired connection i havent even tested but would probably work in the same way.

I followed the instructions on this page - http://www.putorius.net/2011/03/installing-fedora-11-on-hp-mini-1030nr.html

After that it still didnt really work, so i followed these instructions on this page - http://forums.fedoraforum.org/showthread.php?t=269331 namely this command:

wget http://downloads.openwrt.org/sources/broadcom-wl- tar xjf broadcom-wl- cd broadcom-wl-     su b43-fwcutter -w /lib/firmware wl_apsta_mimo.o  

Finally to get the wireless to work, I went into the network management settings by clicking on the network icon then on manage network connections, finally the wireless tab was clickable so i opened it, then i added a wireless network, In the SSID field, click the scan button, then select your wifi network. next, in the BSSID click select, then ok and close. then click ok and it should ask you for your network password.

this worked for me, i hope it works for you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.